Nextcloud letsencrypt cert unable to create

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

i am using nextcloud installed on raspberry pi 4. wanted to create ssl cert for NC. when i entered domain name, email address and hit apply to create letsencrypt certificate i ran into below error everytime. pls note i have disabled firewall from both router as well in pc installed internet security. pls assist.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/nextcloud for all unmatched domains.
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Timeout during connect (likely firewall problem)

  • The following errors were reported by the server:

Type: connection
Detail: Fetching
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

You need a functional HTTP site before you can secure it (via HTTP authentication).

curl -Iki
curl: (56) Recv failure: Connection reset by peer

See: Let's Debug (

thanks Rudy for prompt response.

when i type it take me to nextcloud login page. pls see below screen shot. pardon me if i am doing something wrong as i am a noob.
can you pls guide what i need to do exactly?

1 Like

Is that from the Internet?
If not, try it from outside your local network.
If so, then you may be using some sort of GeoLocation blocking - that is preventing LE, Let's Debug, and me from reaching your site via HTTP.

1 Like

Do you have the correct portmaps (TCP port 80 and TCP port 443) in your router enabled?


Hi again

I tried accessing next cloud over internet and it is working fine. Pls see below screen shot

Doesn't work for me (in Australia) so it probably doesn't work for Let's Encrypt as well. Make sure you're not just accessing it over your local Wifi (use your phone data), which would hide the problem.

Yes i am able to access nextcloud over phone data. Screenshot sent earlier shows NC dashboard over mobile data

Fails from the U.S. too:

curl -Iki
curl: (56) Recv failure: Connection reset by peer

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.