SSL-certificate not working DirectAdmin CentOS7


#1

My domain is:
webconexus.cloud

I ran this command:
Set-up SSL certificate in DirectAdmin

It produced this output:
Requesting new certificate order…
Processing authorization for www.webconexus.cloud…
Error: http://www.webconexus.cloud/.well-known/acme-challenge/letsencrypt_1542973613 is not reachable. Aborting the script.
dig output for www.webconexus.cloud:
37.252.122.225
Please make sure /.well-known alias is setup in WWW server.

My web server is (include version):
Apache

The operating system my web server runs on is (include version):
CentOS 7

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
DirectAdmin

Hello,

I try to set-up my SSL certificate but I am getting back this error. I set-up the .well-known folder, check it here:
http://www.webconexus.cloud/.well-known/acme-challenge/test.txt

My open firewall ports:
ports: 80/tcp 443/tcp 993/tcp 465/tcp 143/tcp 22/tcp 20/tcp 2222/tcp 995/tcp 587/tcp 25/tcp 110/tcp

DNS records:
2 times A

Someone knows what I am doing wrong here? Thanks in advance.

Regards,

Roef


#2

Lol totally forgot to use this command:

cd /usr/local/directadmin/custombuild
./build rewrite_confs

I was under the impression that custombuild 2.0 already had this done. But it’s working now


#3

and
http://webconexus.cloud/.well-known/acme-challenge/test.txt
Return 404 errors.