SSL activation for Noobs! B+ intermediate certificate issue


#11

yes i do have it, but when i try and paste the ca bundle into certificate i get an error saying - The certificate uploaded is NOT for the domain name


#12

did that “ca bundle” contain more than one “-----BEGIN CERTIFICATE----- and -----END CERTIFICATE-----” ?

if not, then add both the “certificate” and the “ca bundle” combined - so it does contain more than one “-----BEGIN CERTIFICATE----- and -----END CERTIFICATE-----”


#13

ok added both and got an error - It appears this certificate is in pem format / requires intermediates to function, this is not supported on free hosting. :frowning:


#14

If your host doesn’t support it, then I can’t help a lot I’m afraid. You need to talk to your host (or move to one that does).


#15

Any idea of a free host that supports ssl! Got ya man thanks a ton :slight_smile:


#16

Have a look at the list of hosts who support Let’s Encrypt There are a number of “free” hosts there.


#17

I checked every single host and none are free :frowning: If you could recommend any or should i end the hunt and just go for something paid?


#18

I don’t know your exact requirements - you could try one like onesite.co - I haven’t used them myself, but it’s free hosting that support Let’s Encrypt certs and use cpanel.


#19

Ok awesome will try it out :slight_smile: Honestly completely new to this and just need that secure padlock in green and need to be able to upload my website :stuck_out_tongue: :slight_smile: But thanks a lot you have been more then helpful already and i really appreciate your time :slight_smile:


#20

Hey serverco, I have made an account and been successful with the lets encrypt plugin but it still shows a unsecured warning in older android devices . after change of host my certificate has been upgraded to an A-
and the chains issues have disappeared.
please help
Thanks :slight_smile:


#21

You need a dedicated IP address for your domain if you want older devices that don’t support SNI to work.


#22

Oh sorry for double posting will delete that thread!

The android version i am using is 4+ …
https://www.ssllabs.com/ssltest/viewClient.html?name=Android&version=4.0.4&key=58

Even this shows an unsecured error. Does it require a dedicated IP as well?
(sorry bare with me )
Thanks


#23

I’m not sure I follow how that is related to your site. That link is showing that Android 4.4 supports the insecure SSLv3. However you aren’t using SSLv3 on your domain, so it’s not relevant.


#24

Ok :slight_smile: So is there anyway for me to get rid of the unsecred error on android devices. ( i dont get them on any other websites though) Thanks :slight_smile: Also according to you my SSL is as secure as it should be? :slight_smile: And i am good to go :slight_smile:


#25

Is this an error you are seeing on a specific device ? I just tested with android and it was fine, and SSLabs says it’s fine ( apart from for older android devices).

If it’s from a specific device, can you provide the exact error ? or screenshot ?


#26

Hi yes i uploaded the image and i have tried from 2 phones same error

Also i know many people who would be accessing my website might have similar models of phones, hence i need it running. ( otherwise ill just have to leave as an http version since this would just scare people away ) :slight_smile:
Thanks


#27

Even on the native samsung browser i get the same error.

ALSO ANDROID version - 4.4.2

Also tried it on here - if this helps you determine the issue -

Is it a shortcoming of free ssl?


#28

I’m seeing issues where the intermediate is both absent and provided depending on the connection attempt. This may be an issue with your hosting provider. I suggest contacting them and seeing if they can provide any help.


#29

But i never get issues accessing https from my ios phone or laptop ever! Works like a charm everytime. i mean if i just access both at the same time - the android keeps bringing the unsecure page up! Also its everytime i access it from the android that i get the same issue. + I did change my host all together as well and the problem still persists even though my ratings gone upto A-.


#30

I’m seeing no problems on my various Android devices, but some tests are indicating that the intermediate is not being served.

Depending on how long ago you moved hosting, the device may still have the old information cached and it’s pulling up that. If you switched DNS, it can take 24-48 hours for everything to see the new hosting location.