SSH Connections doesnt work any more

and i just realised that ftp also doesnt work

it sounds as if the permissions in /etc/ssh ( possibly all /etc) are incorrect.

What are the ownership / permissions of /etc/ssh and the files in that folder ? They should be root and generally 600 or 644 for public files

i get as result 777 and user root

OK, not sure why they have changed, but that's the problem.

Where did you install certbot to ? (which directory )

I'd run the commands

chmod 755 /etc/ssh
chmod 600 /etc/ssh/*
chmod 644 /etc/ssh/*.pub

Then test and see if you can connect via ssh ( and if not, what the error is in auth.log )

finallyyy it works thank you so much

i used this instruction:

1 Like

Glad that fixed it. I can’t see anything in those instructions that would have changed permissions in the /etc/ssh foolder.

ok i only used this instruction and after that it doenst work any mor but now it works :slight_smile:

1 Like

aaaaand i got the error again -.-

fixed it somthing chnaged all of my permissions :cry:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.