Some Challenges Have Failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ( for the SSL certificate)

I ran this command: (I am using Nginx Proxy Manager. Heres the Log) :

Error: Command failed: /usr/bin/certbot certonly --non-interactive --config "/etc/letsencrypt.ini" --cert- 
name "npm-39" --agree-tos --email "" --preferred-challenges "dns,http" -- 
domains "" 
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /data/letsencrypt-acme-challenge for all unmatched domains.
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.

at ChildProcess.exithandler (child_process.js:308:12)
at ChildProcess.emit (events.js:314:20)
at maybeClose (internal/child_process.js:1051:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

It produced this output: ^^^^^^^^^^^^^^

My web server is (include version): Apache/2.4.41 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 20.04

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
Nginx Proxy Manager

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): /

Hi @Immuc

please read your older topic:

Exact the same error message, exact the same authenticator. Webroot not working -> your webroot is wrong, fix that.

1 Like

Ok so first, its not the same message. Its another error.
Also It worked a week ago and now it does not work anymore.

That domain doesn't have an ip address, not ipv4, not ipv6. So webroot can't work.

Please read required basics:


to understand your error message.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.