[Solved] Renewal of Certs (Regarding Well-Known)

I am using nginx and I know many have face this issue before. However I am still confuse on this /.well-known/acme-challenges.

Anyone please advise me on how do I get around with this issue.

Thank You so much.

Processing /etc/letsencrypt/renewal/mydomain.com.conf

Cert is due for renewal, auto-renewing…

Renewing an existing certificate
Performing the following challenges:
http-01 challenge forr mydomain.com
http-01 challenge for mydomain.com
Waiting for verification…
Cleaning up challenges
Unable to clean up challenge directory /var/www/wordpress-application/.well-known/acme-challenge
Attempting to renew cert from /etc/letsencrypt/renewal/ mydomain.com.conf produced an unexpected error: Failed authorization procedure. indonesianbbq.com (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://mydomain.com/.well-known/acme-challenge/_A2YgkFUvgfsVo18qhEjwoW1q-ndLeMiYWyBYiPvJG4: "

403 Forbidden

403 Forbidden

", mydomain.com (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://mydomain.com/.well-known/acme-challenge/yo50UFzKmjFmYxZPaSP8CpdjShRM_URgzz0-eHWlW94: " 403 Forbidden

403 Forbidden

". Skipping.

Hi @brijq,

This is normally a result of a web server configuration change of some sort between the time that you issued your certificate and the time that you tried to renew it. In this case, it looks like you might have added some kind of configuration to your web server that prevents it from serving paths that start with a dot ("."). If you look in your nginx error logs, you might see more details about why it thought it wasn’t allowed to serve the challenge file—or if you can remember any kind of configuration changes that you made to nginx since obtaining the certificate.

Thank You so much. It turns out to be some permission issue again to the path /.well-known. Thank You so much.

Its solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.