[SOLVED] Problem in Removing and Reissuing Certificate

I had a website under linuxhomeserver.duckdns.org with a LetsEncrypt certificate. When I moved it to linuxhomeserver.com I was getting the obvious certificate warnings. I imagine my problems began, when rather than revoking the first cert, I deleted it (sudo certbot delete). When I tried to add the new .com domain, I got error messages about the certificate not being available. I tried to start afresh by removing certbot (apt-get remove cerbot, and then apt-get purge certbot) but still ran into difficulties. I can see from the .conf files in /etc/apache/sites-available that the .duckdns.org domain is still listed in them.

I tried some simple edits of these files, which I could easily undo, and was getting messages that my server has HTTP configured on the HTTPS port. This doesn’t make sense to me as I haven’t changed any port settings. I’ve browsed the logs at /var/log/apache2/error.log and /var/log/letsencrypt, but other than repeating some of the error messages I was getting, nothing obvious stands out to me.

My firewall is set up simply to allow incoming traffic on 22, 80 and 443. How do I wipe the slate clean and start over?

I guess you know this now, but it’s not safe to delete your certificates until you’ve removed all references to them from your Apache configuration :slight_smile:

I think, all that should be needed is to remove the VirtualHost on port 443 that was added for the duckdns domain (remove the whole <VirtualHost *:443> ... </VirtualHost> section, not just the SSLCertificateFile and related lines) and then run certbot again.

If that doesn’t help, posting what your Apache configuration looks like now would probably help us to figure out what’s wrong.

1 Like

Your page seems to be working with a valid Let’s Encrypt certificate that will expire on Wednesday, March 14, 2018. The weird thing is that that main WordPress backround image that should be there is not showing up.
Here is what that looks like on your website “linuxhomeserver.com

Thanks, that fixed it! I went to /etc/apache2/sites-available and edited the 000-default-le-ssl.conf file to comment out all lines for the <VirtualHost *:443> section. Once I restarted apache and ran certbot --apache again, I was able to get a new cert.

All the images stopped showing, I presume it was because they still had their address as linuxhomeserver.duckdns.org. Once I used a plugin to change all the links to the new .com address they are showing again. Thanks for your help on this.


Awesome, if you have anymore questions don’t hesitate to ask us!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.