[SOLVED] Is there any validation checks I can perform before trying LetsEncrypt


#1

I have about 8 personal sites on DigitalOcean and all are HTTP. I successfully encrypted a free.domain.tk to test LetsEncrypt but now it is inaccessible.

I think when the server was updated from Linux 14.04 to 16.10 the trouble began…

I think the problem is because, I foolishly and permanently redirected (using 301) to the HTTPS site.

I would like to start again and have just created another free test which is currently propagating. I was wondering if there are any tests which can be performed before trying to encrypt the new site.


#2

I’d always start by using the staging / test server ( see https://letsencrypt.org/getting-started/ and https://letsencrypt.org/docs/staging-environment/ ) since that doesn’t have the same rate limits on it. Once you have everything working there, then change to the full server.


#3

@serverco many thanks for the response unfortunately it did not solve the problem.


#4

YIPPEE - Success :slight_smile:

Most surprised that I received the following email from Google!

I have no idea of the incorrect SSL Certificate origin.

Yesterday I deleted the SSL and installed LetsEncrypt again without success.

Today it works! It looks as though overnight the faulty URL has been de-propagated/un-propagated (?)

Lessons to be learned:

  1. Do not use 301 to rewrite the HTTP URL to HTTPS because if there are any mistakes it takes forever to revert. Far better to use a 302 until the URL has proved to be successful. The rigid 301 change can then be made or maybe never?.
  2. Beware of Ubuntu upgrades from 14.04 to 16.01 which may have been the problem, if not then it was co-incidental the HTTPS URL stopped working.
  3. Test your site with a free URL and monitor success. I am delighted to say has worked fine otherwise my other sites would have been down for well over a fortnight.
  4. Never blindly trust tutorials :slight_smile:

Edit:
Added email date.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.