[Solved] Getting certificate and key: no such file or directory


#1

Hi Everyone,
i already apologize for my English.

I hope you can help me getting the certificate and key for my website D:

I already installed the certificate in another website and all goes fine but not here D:

i’m using MacOS Terminal to install it

My domain is:

tommasogregianin.com

I ran this command after i correctly follow these steps on:

**cat fullchain.pem**

** cat key.pem**

It produced this output:

No such file or directory

My web server is (include version):

server153.hostinger.it

The operating system my web server runs on is (include version):

Apache/2.4

My hosting provider, if applicable, is:

Hostinger.it

I can login to a root shell on my machine (yes or no, or I don’t know):

don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

cPanel from hostinger

Thank You so much

Tommaso


#2

What files actually exist in that directory structure? What’s the output of the following (replace x123011738 as per the guide):

find /home/x123011738/acme-client/data/

#3
/home/u216528592/acme-client/data/
/home/u216528592/acme-client/data/accounts
/home/u216528592/acme-client/data/accounts/acme-v01.api.letsencrypt.org.directory.pem
/home/u216528592/acme-client/data/certs
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com/cert.pem
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com/fullchain.pem
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com/chain.pem
/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com/key.pem

EDIT

just my fault xD i didn’t see that the certificate was installed in: /home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/tommasogregianin.com

not in

/home/u216528592/acme-client/data/certs/acme-v01.api.letsencrypt.org.directory/

Thanks xD


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.