[Solved] Correct zName not found for TLS SNI challenge


#1

Hi everyone,
I’m facing an issue with differents linux distributions. I’d like to install letsencrypt in the domaine webinti.ovh.
I have a Debian 8 VPS with ISP CONFIG and apache2 i followed this tutorial : https://www.howtoforge.com/tutorial/perfect-server-debian-8-jessie-apache-bind-dovecot-ispconfig-3/1/.
So in /etc/root i cloned the Github repo and launched it with ./letsencrypt-auto. It recognized my domain so I clicked OK and accepted the agreements.
And after I had this issue :

Failed authorization procedure. www. webinti.ovh (tls-sni-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Correct zName not found for TLS SNI challenge. Found ‘mailconfig.ovh.net

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www. webinti.ovh
    Type: urn:acme:error:unauthorized
    Detail: Correct zName not found for TLS SNI challenge. Found
    mailconfig.ovh.net

When i enter this command :->
./letsencrypt-auto certonly --standalone -d webinti.ovh -d www.webinti.ovh

IT SAYS:

  • Congratulations! Your certificate and chain have been saved at
    /etc/letsencrypt/live/webinti.ovh/fullchain.pem. Your cert will
    expire on 2016-05-02. To obtain a new version of the certificate in
    the future, simply run Let’s Encrypt again.

When i visit my website with https it doesnt work.
Can you please help me to find out what i’ve missed :slightly_smiling:
Thanks
Tim


#2

I resolved my problem by myself.
I totally removed ISPCONFIG 3, i removed and purged apache2.
Reinstall Apache2. Configured my domain in /etc/apache2/sites-enabled, configured the named.conf.local and db.domaine.com in /etc/bind.
Re-launched the letsencrypt script and works great !!


#3

Please find my answer to this issue on How to resolve the "Correct zName not found for TLS SNI challenge" error when i try renew certificate

Best regards
Frederick Thomssen