SERVFAIL looking up A record


#1

Can you help me with this error?

Failed authorization procedure. (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for

IMPORTANT NOTES:

  • The following errors were reported by the server:

Type: connection

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.
sudo ./letsencrypt-auto certonly --webroot -w
Checking for new version…
Requesting root privileges to run letsencrypt…
/home/admin/.local/share/letsencrypt/bin/letsencrypt certonly --webroot -w
Failed authorization procedure (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for example.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: example.com
Type: connection
Detail: DNS problem: SERVFAIL looking up A for

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.


#2

Hello @richard457,

As @serverco said:

You have a DNS problem, 2 of 3 of your dns servers are not responding.

$ dig +short @ns1.digitalocean.com streamupbox.com
;; connection timed out; no servers could be reached

$ dig +short @ns2.digitalocean.com streamupbox.com
;; connection timed out; no servers could be reached

$ dig +short @ns3.digitalocean.com streamupbox.com
104.131.119.32

Good luck,
sahsanu


#3

Your nameservers are now returning the correct values, so should be worth trying again now.


#4

After trying again thi is what I am getting

Failed authorization procedure. test.com (tls-sni-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Correct zName not found for TLS SNI challenge. Found ‘www.test.com, test.com’, www.streamupbox.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for www.streamupbox.com, streamupbox.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for streamupbox.com, www.test.com (tls-sni-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Correct zName not found for TLS SNI challenge. Found ‘www.test.com, test.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: test.com
    Type: unauthorized
    Detail: Correct zName not found for TLS SNI challenge. Found
    www.test.com, test.com

    Domain: www.test.com
    Type: unauthorized
    Detail: Correct zName not found for TLS SNI challenge. Found
    www.test.com, test.com


#5

This is code I am using with errors always
/opt/letsencrypt$ /opt/letsencrypt/letsencrypt-auto --config /etc/letsencrypt/cli.ini -d streamupbox.com -d www.example.com certonly
Checking for new version…
Requesting root privileges to run letsencrypt…


#6

I forgot to mention that The connection from which I am using is A proxy Is it a problem?


#7

It depends exactly how the proxy is set up. As long as it’s forwarding the requests properly it should be fine.

I can’t reach https://streamupbox.com/ though - it would appear that port 443 isn’t set up correctly on that server (or the proxy isn’t forwarding correctly )


#8

This is my apache configuration
<VirtualHost *:80>

    ServerName example.com
    ServerAlias 104.131.119.32

    #ServerAdmin admin@example.com
    DocumentRoot /var/www/html/streamupbox/public

    <Directory /var/www/html/streamupbox/public>
    # Don't show directory index
    Options -Indexes +FollowSymLinks +MultiViews

    # Allow .htaccess files
    AllowOverride All

    # Allow web access to this directory
    Require all granted
</Directory>

#9

When I do an nslookup for that host, I get the following reply:

nslookup streamupbox.com
;; Got SERVFAIL reply from 213.133.98.98, trying next server
;; Got SERVFAIL reply from 213.133.99.99, trying next server
Server:         213.133.98.98
Address:        213.133.98.98#53

** server can't find streamupbox.com: NXDOMAIN

Seems it’s not registered and/or setup in DNS anywhere


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.