SERVFAIL looking up A for xxxxxx.com domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: xxxxxx.com

I ran this command:
sudo certbot certonly --webroot --webroot-path=/home/xxxxxx/www/xxxxxx.com -d xxxxxx.com -d www.xxxxxx.com

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for xxxxxx.com
http-01 challenge for www.xxxxxx.com
Using the webroot path /home/xxxxxx/www/xxxxxx.com for all unmatched domains.
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. www.xxxxxx.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for www.xxxxxx.com, xxxxxx.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: SERVFAIL looking up A for xxxxxx.com

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: www.xxxxxx.com
   Type:   connection
   Detail: DNS problem: SERVFAIL looking up A for www.xxxxxx.com

   Domain: xxxxxx.com
   Type:   connection
   Detail: DNS problem: SERVFAIL looking up A for xxxxxx.com

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My web server is (include version): NGINX

The operating system my web server runs on is (include version): Ubuntu 17.04

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO, command line baby!

A NOTE FROM ME:
To clarify - I have 2 other domains on this same server (same IP) that has Let’s Encrypt installed successfully. I do have correct A Records and everything set as supposed to be (I took exact same steps like with my other domains) so I don’t understand why this one doesn’t go through.

Help!

UPDATE: masked domain name

http://dnsviz.net/ [redacted]

The domain has a DS record set at the registry, but the authoritative DNS servers are not actually signing the zone.

No validating resolver, such as Google Public DNS or that used by Let’s Encrypt, can resolve your domain.

https://www.namecheap.com/support/knowledgebase/article.aspx/9723/2232/managing-dnssec-for-domains-pointed-to-premium-or-basicdns

Namecheap has a history of issues with DNSSEC.

Since you’re using their DNS hosting, they manage the DS settings automatically, but unreliably.

If DNSSEC is turned off in their control panel, try turning it on.

(Their DNSSEC stack also sometimes fails, but I’m not sure if you have any choice.)

https://www.namecheap.com/support.aspx

You should also contact support, but they may not help.

2 Likes

@mnordhoff - appreciate your reply! I just switched it to ON in my dash, let’s see within an hour or so if this changes anything. Would you mind to put xxxxxx in the domain name? I would prefer not to reveal it.

UPDATE 5min later: I worked! Switching DNSSEC on helped and I was able to issue the certificate. Now, the question is - should I keep it on or I can safely turn it off now?

Alright. The thread has been crawled by search engines already, though. :grimacing:

I’ve taken the liberty of hiding the edit history on both of our posts, so the domain can’t be seen there.

Keep in mind that Let’s Encrypt certificates are all archived in public Certificate Transparency logs.

https://crt.sh/?Identity=%&iCAID=16418

Great! :smile:

I don’t know. :sweat: In theory, it would be safe. But in theory, it wouldn’t have been broken in the first place!

You can give it a try. It may work fine. It may break the domain (with validating resolvers) until you turn it back on again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.