Second subdomain receive the certificate for first subdomain


#1

Hello everyone, I have a problem with two subdomains with the same IP.

When i execute: sudo certbot certonly -d demo.xxx.yyy, all goes clear and i recive the certificate, but when i put this certificate on production, the browser say this is for secure.xxx.yyy (the second subdomain that i controll)

The SNI option it’s activated and configured.


#2

Hi @roldan

please share your domain names and your configuration files.


#3

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#4

My domain is: secure.ctech.financial and demo.ctech.financial

I ran this command: sudo certbot --authenticator webroot --installer nginx -d demo.xxx.xxx

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Cert not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/demo.xxx.xxx.conf)

What would you like to do?

1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for demo.xxx.xxx

Select the webroot for demo.xxx.xxx:

1: Enter a new webroot

Press 1 [enter] to confirm the selection (press ‘c’ to cancel):

** Invalid input **
Press 1 [enter] to confirm the selection (press ‘c’ to cancel): 1
Input the webroot for demo.ctech.financial: (Enter ‘c’ to cancel):/www/demo
Waiting for verification…
Cleaning up challenges
Generating key (2048 bits): /etc/letsencrypt/keys/0000_key-certbot.pem
Creating CSR: /etc/letsencrypt/csr/0000_csr-certbot.pem
Cannot find a VirtualHost matching domain demo.xxx.xxx.

IMPORTANT NOTES:

  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at
    /etc/letsencrypt/live/demo.xxx.xxx/fullchain.pem. Your cert
    will expire on 2018-11-12. To obtain a new or tweaked version of
    this certificate in the future, simply run certbot again with the
    “certonly” option. To non-interactively renew all of your
    certificates, run “certbot renew”

My web server is (include version): nginx/1.10.3

The operating system my web server runs on is (include version): debian 9.4.0

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#5

After that, did you manually install the certificate into nginx? Does nginx have a demo.ctech.financial virtualhost set up?


#6

Yes, i install manually the certificate into nginx
and Yes, the have demo.ctech.financial virtual host configured


#7

Can you show us? 


#8

Solved, there is a problem with the DNS Provider.

Thanks a lot for que quick response.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.