Second certificate in SSL Test and no SNI support

I have several domains hosted on one server. All are virtual hosts on apache 2.4. The domain in question is: webimagedownloader.com. SSL Server test from SSLLabs.com shows strange things after I upgraded to ACMEv2 a couple of days ago:

https://www.ssllabs.com/ssltest/analyze.html?d=www.webimagedownloader.com

  1. This site works only in browsers with SNI support.
  2. It has second the certificate where the subject is another domain of mine hosted on the same server: free-photo-screensaver.com. And the rest of my domains hosted on this server have free-photo-screensaver.com as a second certificate. While the SSL Test for the free-photo-screensaver.com is perfect:

https://www.ssllabs.com/ssltest/analyze.html?d=free-photo-screensaver.com

And that’s what I’d like to see on the domain in question and all other domains on this server.

So, what do I do? What kind of configuration setting do I have to modify in order to get rid of both 1. and 2. ?

My domain is: webimagedownloader.com

My web server is (include version): Apache/2.4.10 (Debian)

The operating system my web server runs on is (include version): Debian GNU/Linux 8.11 (jessie)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.3.0

1 Like

Please read more information about SNI. E.g. https://en.m.wikipedia.org/wiki/Server_Name_Indication

If you still don’t understand why you’re getting that message after reading the above link, please let us know.

Hint: you don’t have to worry.

3 Likes

You can choose which one will get the “This site works only in browsers with SNI support.” but you cannot remove it, unless you get a second ip address. The first virtualhost in the apache config won’t get that remark.

In any case, don’t worry about it. All (I’m not saying most, am saying all) modern browsers have SNI support. Unless your clients use IE6 on Windows XP, that is.

3 Likes

OK, thank you very much guys! I’ll sleep better today :upside_down_face:

2 Likes