Running "./certbot-auto --apache" doesn't really do anything - how to debug?


#1

I am running Ubuntu with Apache 2.4.7 (with libaugeas0 package also installed). After downloading successfully, I run the command ./certbot-auto --apache and it returns:

Usage: certbot-auto [OPTIONS]
A self-updating wrapper script for the Certbot ACME client. When run, updates
to both this script and certbot will be downloaded and installed. After
ensuring you have the latest versions installed, certbot will be invoked with
all arguments you have provided.

Help for certbot itself cannot be provided until it is installed.

–debug attempt experimental installation
-h, --help print this help
-n, --non-interactive, --noninteractive run without asking for user input
–no-self-upgrade do not download updates
–os-packages-only install OS dependencies and exit
-v, --verbose provide more output

All arguments are accepted and forwarded to the Certbot client when run.

But nothing else happens. Am I doing something wrong? Running ./certbot-auto certonly seems to work as normal. How do I even begin to debug why it’s not working?


#2

I ran into this too. It seems like the first time it has to be run without any flags and after that it works as expected. This is undocumented behaviour and quite annoying for idempotent setups like ansible, etc.


#3

Thank you. I spent hours trying to work that out and it was as simple (yes as complicated) as that. Docs need updating for that.


#4

I ran into the same issue could you expand on how you got past this? How do you “run it without flags”?