[Resolved] Renew fail after update certbot-auto 0.9.3 to 0.10.1


#1

I ran this command:
/opt/letsencrypt/certbot-auto renew

It produced this output:
[…]
creating build/temp.linux-x86_64-2.7/build/temp.linux-x86_64-2.7
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -I/usr/include/python2.7 -c build/temp.linux-x86_64-2.7/_openssl.c -o build/temp.linux-x86_64-2.7/build/temp.linux-x86_64-2.7/_openssl.o
{entrée standard}: Messages de l’assembleur:
{entrée standard}:87023: Avertissement: fin du fichier n’est pas à la fin de la ligne; nouvelle ligne insérée
{entrée standard}: Erreur: ouverture CFI à la fin du fichier; directive .cfi_endproc manquante
gcc: internal compiler error: Processus arrêté (program cc1)
Please submit a full bug report,
with preprocessed source if appropriate.
See http://bugzilla.redhat.com/bugzilla for instructions.
error: command ‘gcc’ failed with exit status 4

Command “/home/ec2-user/.local/share/letsencrypt/bin/python2.7 -u -c “import setuptools, tokenize;file=’/tmp/pip-build-GqFLB9/cryptography/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-DxYjmf-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/ec2-user/.local/share/letsencrypt/include/site/python2.7/cryptography” failed with error code 1 in /tmp/pip-build-GqFLB9/cryptography

Certbot has problem setting up the virtual environment.

My operating system is (include version):
EC2 Amazon Linux AMI

My web server is (include version):
Nginx


#2

Solution : https://github.com/certbot/certbot/issues/2324#issuecomment-177590314


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.