Renewal problem; macOS Server 5.5


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: sevardin.com

I ran this command: sudo certbot renew

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/fates.org.conf

Cert not yet due for renewal


Processing /etc/letsencrypt/renewal/sevardin.com.conf

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for sevardin.com
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (sevardin.com) from /etc/letsencrypt/renewal/sevardin.com.conf produced an unexpected error: Failed authorization procedure. sevardin.com (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://sevardin.com/.well-known/acme-challenge/4j16_Id4202qGhT8yF9tMMR9qRlyau-HGGLZUa779d8: "

404 Not Found

Not Found

<p". Skipping. All renewal attempts failed. The following certs could not be renewed: /etc/letsencrypt/live/sevardin.com/fullchain.pem (failure)

The following certs are not due for renewal yet:
/etc/letsencrypt/live/fates.org/fullchain.pem (skipped)
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/sevardin.com/fullchain.pem (failure)

1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

My web server is (include version):
Server version: Apache/2.4.28 (Unix)
Server built: Oct 9 2017 19:54:20

The operating system my web server runs on is (include version):
macOS High Sierra 10.13.3

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

I set up certs for two domains on this server: fates.org and sevardin.com. I am able to renew fates.org, but sevardin.com began failing with the above after the first round of renewals. I have tried placing a readable file in $WEBROOT/.well-known/acme-challenge and am able to view the file from a browser.

The machine where these domains are hosted crashed a few days ago—but after the first failed renewal attempt—and $WEBROOT has changed as a result. This change did not affect fates.org’s renewal. (I restored the machine from a backup from the day before I had renewed the fates.org certificate.) I have checked and verified permissions for the domain, verified the IP address, and am currently able to call up https://sevardin.com with the current certificate.

I’m at a loss for what to try next. The certificate for sevardin.com expires on 6 March 2018.


#2

Please place a test file in the directory $WEBROOT/.well-known/acme-challenge/ (for sevardin.com) which we can try to access.


#3

I added “foo.txt” to that directory and can access it at:

http://sevardin.com/.well-known/acme-challenge/foo.txt


#4

Is the webroot directory in /etc/letsencrypt/renewal/sevardin.com.conf still the one you expect? (Remember that the webroot path itself should not contain the /.well-known/acme-challenge.)


#5

Ah! That was it. Many thanks for your help. Changing the path fixed the renewal. (Why it still successfully renewed the other site, which also had a bad path, I have no idea… but am less concerned about that now.)


#6

If you originally got the other certificate with -a apache or --apache, the CA would still allow a validation by the deprecated HTTPS-01 technology on port 443, which is unaffected by redirects. That’s one possibility.


#7

I obtained both original certs at the same time from letsencrypt.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.