Renewal Delay - how long?

I just renewed my just expired domains, but they didn't seem to take effect. Not sure if it's my browser cache, but it's been half an hour now. How long of a delay I should expect before concluding that I did something wrong?

My domains are:

I ran this command:
certbot certonly --manual -d
...and the same for the other domains. They were successful.

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 20.04.1

My hosting provider, if applicable, is: A2Hosting

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no. just command line.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Thank you! :slight_smile:


Hi @rmoffatt

that doesn't restart your webserver.

That's required.


Thank you, @JuergenAuer. I forgot to mention, I ran this after the renewals:

sudo apachectl restart

Just did it again to be sure :sweat_smile: Certs still not updated when I attempt to reach the domains.


The not working result is expected.

Checking with my browser there is one certificate with all three domain names.

But you have created three certificates with one domain name. So the used certificate isn't replaced.

Create one certificate with 3 domain names.


Perfect. Thank you!

certbot certonly --manual -d -d -d
sudo apachectl restart
-> Success.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.