Renew SSL failure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot renew --dry-run

It produced this output: failed to renew certificate, some challenges have failed

My web server is (include version): the latest xampp

The operating system my web server runs on is (include version): windows 11

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot version 2.7.2 standalone

Please provide the entire output.

1 Like

my xampp is running on port 8080 and 444
i also have another webserver that runs on port 80

this is my cerbot conf

Is that webroot path from, the renewal configuration file still correct?

Let's Encrypt always validates on port 80 using the http-01 challenge, which is used by the webroot plugin. It's mandated to do so. You can't force the validation on port 8080. So Let's Encrypt tries to validate on your "other webserver", which probably is not the correct one where Certbot puts the challenge file.

1 Like

actually i'm redirecting from the port 444 with xampp webserver to my old appserv with port 80..
all the web files located in the path D:\appserv\www, i've tried to change it and rerun the renewal and i got this error

1 failure left but i'm confused because it shows me the same path, and also i always get the same info if my SSL is not due

The failure just seems to come from a "Copy" of the other renewal configuration file? Why is that copy there anyway?


ah i see... thank you so much..
i forgot that i make a copy for backup if my conf files go wrong, but i put it in the same directory

1 Like

@Mj88 Since you are just starting out with Certbot on Windows I wanted to highlight this notice from the Certbot team that came out today.

You seem to be actively testing your configuration as I see you got certs from the LE staging system very recently.

You might want to consider an alternative to Certbot to get longer term support. See their topic for some suggestions


thank you so much for the info


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.