Http-01 challenge fails

Hello,
I have problem to renew certs with one server. This current cert is now renewd by using different host. I change dns and moved files to and back that server. On “spare” server I can do “certbot-auto renew --dry-run” and it works ok.

On problematic server “certbot-auto renew --dry-run” still fails. I do not have idea, what’s wrong.

My domain is: lintulehti.testi.birdlife.fi

I ran this command: ./certbot-auto renew --dry-run

It produced this output:

[root@mongodb letsencrypt]# ./certbot-auto renew --dry-run
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/lintulehti.testi.birdlife.fi.conf


Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator standalone, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for lintulehti.testi.birdlife.fi
Waiting for verification…
Challenge failed for domain lintulehti.testi.birdlife.fi
http-01 challenge for lintulehti.testi.birdlife.fi
Cleaning up challenges
Attempting to renew cert (lintulehti.testi.birdlife.fi) from /etc/letsencrypt/renewal/lintulehti.testi.birdlife.fi.conf produced an unexpected error: Some challenges have failed… Skipping.


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/lintulehti.testi.birdlife.fi/fullchain.pem (failure)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)


1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: lintulehti.testi.birdlife.fi
    Type: connection
    Detail: Fetching
    http://lintulehti.testi.birdlife.fi/.well-known/acme-challenge/Cyd3vMpYsJ6svWJuTXa4dCyU9DoFalKqz9qAJ4i4Pew:
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

The operating system my web server runs on is (include version):
CentOS Linux release 7.6.1810 (Core

I can login to a root shell on my machine (yes or no, or I don’t know): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.38.0

Hi @AnttiJ

standalone is hard to debug, that starts an own webserver.

Your domain is invisible - https://check-your-website.server-daten.de/?q=lintulehti.testi.birdlife.fi

Domainname Http-Status redirect Sec. G
http://lintulehti.testi.birdlife.fi/
195.60.204.41 -14 10.044 T
Timeout - The operation has timed out
https://lintulehti.testi.birdlife.fi/
195.60.204.41 -14 10.030 T
Timeout - The operation has timed out
http://lintulehti.testi.birdlife.fi/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
195.60.204.41 Inline-JavaScript (∑/total): 0/0 Inline-CSS (∑/total): 0/0 -14 10.030 T
Timeout - The operation has timed out

But if there is no running webserver, that’s normal. Blocking firewall?

There is a new certificate:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-09-11 2019-12-10 lintulehti.testi.birdlife.fi - 1 entries duplicate nr. 1
Let’s Encrypt Authority X3 2019-06-19 2019-09-17 lintulehti.testi.birdlife.fi - 1 entries

What did you change after creating that certificate?

Yeps there is no webserver and it’s standalone cert.
On port 8080 there is service, listening returns on blue screen, but cert seems to be ok.
https://lintulehti.testi.birdlife.fi:8080/

What did you change after creating that certificate?

I did copy accounts, archieve and renewal from “spare”-server to /etc/letsencrypt-dir and manually create symbolic links to live/lintulehti.testi.birdlife.fi/ -dir
And also change dns to that host

The test of “check-your-website” has a port check, there is port 8080 (Speedport) checked. But there was no answer, now port 8080 is open. Perhaps you have blocked port 80 too.

No, ports 80 & 443 are open, there is no listener is those. I tested them with small node.js prog.
There where no listener on port 8080 before I started it. No changes on fw.