Renew nginx webroot ubuntu 18.04


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:/mbox.toulouse-les-orgues.org

I ran this command: sudo certbot --nginx certonly -n -d mbox.toulouse-les-orgues.org

It produced this output:
Processing /etc/letsencrypt/renewal/mbox.toulouse-les-orgues.org.conf


Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator webroot, Installer None
Attempting to renew cert (mbox.toulouse-les-orgues.org) from /etc/letsencrypt/renewal/mbox.toulouse-les-orgues.org.conf produced an unexpected error: Deserialization error: Expecting value: line 1 column 1 (char 0). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/mbox.toulouse-les-orgues.org/fullchain.pem (failure)

My web server is (include version): ubuntu 18.04

The operating system my web server runs on is (include version):iredmail latest

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot)certbot 0.28.0


#2

Hi @Yourdigitalheart

this is a config file. What’s the content of this file?

Copy the file to another place, then delete it. Your command is comlete, so certbot should create a new file.

PS: Remove the -n flag if you start the command manual.


#3

version = 0.28.0
archive_dir = /etc/letsencrypt/archive/mbox.toulouse-les-orgues.org
cert = /etc/letsencrypt/live/mbox.toulouse-les-orgues.org/cert.pem
privkey = /etc/letsencrypt/live/mbox.toulouse-les-orgues.org/privkey.pem
chain = /etc/letsencrypt/live/mbox.toulouse-les-orgues.org/chain.pem
fullchain = /etc/letsencrypt/live/mbox.toulouse-les-orgues.org/fullchain.pem

Options used in the renewal process

[renewalparams]
account = 8fb63e5d54d9361e158d21793a5650ff
authenticator = webroot
webroot_path = /var/www/html,
server = https://acme-v02.api.letsencrypt.org/directory
[[webroot_map]]
mbox.toulouse-les-orgues.org = /var/www/html


#4

thanks works as well


#5

but don’t renew the date of certificate


#6

If you use certonly, you have to install the certificate manual. Or (minimal) reload your webserver.


#7

yes sorry my mistake need sudo service nginx reload … stupid or too late Thanks for your reactivity.
best regards


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.