Renew fail. expire date in broser is wrong


#1

Hi community,

I tried to renew the certificate. (I think i works) But in all my browsers, chrome, firefox the expiry date is not updated (24 march). If i type certbot renew in my shell i got this:
How can I fix the date in the browsers or what did I wrong?

Thanks

My domain is: not public

I ran this command: certbot renew

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/mydomain.tld.conf

Cert not yet due for renewal


The following certs are not due for renewal yet:
/etc/letsencrypt/live/mydomain.tld/fullchain.pem expires on 2018-07-15 (skipped)
No renewals were attempted.

My web server is (include version): nginx

The operating system my web server runs on is (include version): ubuntu xenial

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Hi @letsASK,

Did you reload/restart nginx?.

Cheers,
sahsanu


#3

Hi sahsanu,

I tried “service nginx reload”. But the date is not updated.


#4

@letsASK, show the output of this command:

certbot certificates

And it should be good to know your domain name.

Cheers,
sahsanu


#5

command shows the correct date: Expiry Date: 2018-07-15 12:02:46+00:00 (VALID: 88 days)

(btw. the "wrong date is 24 april. not march like above)


#6

@letsASK, please, show the entire output.


#7
Saving debug log to /var/log/letsencrypt/letsencrypt.log

-------------------------------------------------------------------------------
Found the following certs:
  Certificate Name: mydomain.tld
    Domains: mydomain.tld www.mydomain.tld
    Expiry Date: 2018-07-15 12:02:46+00:00 (VALID: 88 days)
    Certificate Path: /etc/letsencrypt/live/mydomain.tld/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/mydomain.tld/privkey.pem
-------------------------------------------------------------------------------

#8
grep -REI ssl_certificate /etc/nginx
nginx -t

If this is your domain(removed) then it appears your nginx server is serving the current certificate.


#9

Hi,

Just for the records, I was talking to @letsASK and the problem was an overlapping server_name directive. We have removed the offended conf file and restarted nginx and it is working fine now.

Cheers,
sahsanu


#10

I can confirm. Many thanks to sahsanu!


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.