Renew certbot ssl on Google Cloud

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://muaga.me

I ran this command: on this site: https://www.onepagezen.com/free-ssl-certificate-wordpress-google-cloud-click-to-deploy

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Google Cloud

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): -bash: certbot-auto: command not found
Hello, I installed the sll certificate for WordPress on Google Cloud but I forgot to enable auto-renewal. Now my website cannot be accessed because the certificate has expired. Please help me.

1 Like

Your browser should be able to bypass that warning. It depends on your browser how to achieve that. Please use Google or another search engine to find out how.

Also, the guide you posted shows you had to use SSL through the Google Compute homepage. I’m pretty sure those sites don’t use your expired Let’s Encrypt certificate, so that shouldn’t be a problem anyway to enable auto-renew.

1 Like

Hi @tieunct

then use the the tutorial again.

1 Like

Hi @JuergenAuer
I tried running the commands again. In the second command Generate Certificates: ./certbot-auto certonly --webroot -w /var/www/html/ -d muaga.me -d www.muaga.me
I get the red error:
Challenge failed for domain muaga.me
Challenge failed for domain www.muaga.me
Should I continue running the next command?

Challenge failed for domain muaga.me
Challenge failed for domain www.muaga.me
http-01 challenge for muaga.me
http-01 challenge for www.muaga.me
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:
 - The following errors were reported by the server:
   Domain: muaga.me
   Type:   unauthorized
   Detail: Invalid response from
   https://muaga.me/.well-known/acme-challenge/0q2wRZSVkf248q76AwWv--PqZCsn9W4dOjsrWSdndj4
   [2606:4700:30::6818:7136]: "<!DOCTYPE html>\n<!--[if lt IE 7]>
   <html class=\"no-js ie6 oldie\" lang=\"en-US\">
   <![endif]-->\n<!--[if IE 7]>    <html class=\"no-js "
   Domain: www.muaga.me
   Type:   unauthorized
   Detail: Invalid response from
   https://muaga.me/.well-known/acme-challenge/cbec3AyCfJOUg2_NUQmeOshxFcSQ-9KHuMg8VbdXy3c
   [2606:4700:30::6818:7136]: "<!DOCTYPE html>\n<!--[if lt IE 7]>
   <html class=\"no-js ie6 oldie\" lang=\"en-US\">
   <![endif]-->\n<!--[if IE 7]>    <html class=\"no-js "
   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.
1 Like

If that command doesn’t work, your webroot is wrong.

There is a - new - redirect http -> https. So you have to use your https webroot.

Ah, checking your domain there is the next error - https://check-your-website.server-daten.de/?q=muaga.me

You use Cloudflare. So Certbot sees the Cloudflare error message, because Cloudflare can’t contact your server.

So you don’t have the original configuration.

Remove Cloudflare, create a certificate, add Cloudflare again. Or use the Cloudflare integrated solution to create a Cloudflare certificate.

1 Like

Well thanks, I will try and respond to you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.