Reinstalling Certificates went wrong - ngnix broken

My domain is:

I ran this command:
As I were not able to enter the Wordpress Login (wp-login.php, i got redirected to the IP not domain and I guess this didnt support/was not included in the https certificate). So I wanted to disable the https and followed the steps of this website

cd /etc/nginx
sudo rm sites-available/$mydomain
sudo rm sites-enabled/$mydomain
sudo nginx -t
sudo service nginx restart
sudo certbot delete --cert-name $mydomain

It produced this output: Success, no problem

My web server is (include version): OVH VPS

The operating system my web server runs on is (include version): Ubuntu 21.04

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): OVH, not really

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.18.0

As discribed above, my migrated wordpress website was not really working. The start page with SSL was working ok but the links pointed to the IP (without ssl).
So I tried to change the site/home url in Wordpress but I were not able to access it anymore. So I did the above steps to disable https and now im stuck with this. :

Error while running nginx -c /etc/nginx/nginx.conf -t.
nginx: [emerg] cannot load certificate "/etc/letsencrypt/live/": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/etc/letsencrypt/live/','r') error:2006D080:BIO routines:BIO_new_file:no such file)
nginx: configuration file /etc/nginx/nginx.conf test failed

After requesting a new certificate, ngnix is back again. SO its resolved I guess

You shouldn't have deleted the certificate in the first place; that should not have been part of the "disabling the HTTPS ".

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.