After installing Let's Encrypt on Wordpress [Welcome to Nginx] page appear

Can somebody point me into the correct direction of setting up SSL, without it showing [welcome to Nginx]? it should point back to my wordpress homepage.

I’ve tried both commands :

  • sudo certbot --nginx and
  • sudo certbot certonly --nginx

My domain is: wellnessk.com

I ran this command: sudo certbot certonly --nginx

It produced this output: No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel):

My web server is (include version):Nginx

The operating system my web server runs on is (include version): Ubuntu 18.04 LTS

My hosting provider, if applicable, is: Vultr

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): runcloud

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi @roxz

if you have such a message, your port 80 vHost configuration is incomplete.

What says

nginx -T

Thank you for your reply, I had this as output from the command you provided. In addition how can I complete the configuration please?

#server {
# listen 80;
# listen [::]:80;
#
# server_name example.com;
#
# root /var/www/example.com;
# index index.html;
#
# location / {
# try_files $uri $uri/ =404;
# }

There you see the problem. # means: All rows are inactive, you don’t have a working port 80 vHost.

Check the documentation of your nginx to create a minimal server block.

With

server_name wellnessk.com www.wellnessk.com;

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.