Regarding setting up apache2 for SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:candy-cc.com

I ran this command:certbot certonly --cert-name candy-cc.com --webroot -w /var/www/html -d "candy-cc.com,www.candy-cc.com"

It produced this output:Omit.

My web server is (include version):apache/2.4.54 (Ubuntu) // built:2022-06-08T15:59:33

The operating system my web server runs on is (include version):Ubuntu 22.04 LTS

My hosting provider, if applicable, is:My home server.

I can login to a root shell on my machine (yes or no, or I don't know):Yes.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot 1.21.0

Thank you for your help last year.
I used CentOS last time, but I decided to use Ubuntu.
It doesn't go well when converting to SSL.
Ubuntu has separate configuration files, so I don't know where to put what.
The following attached image is a screenshot of the statements written in apache2.conf, 000-default.conf, default.conf without comments.
thank you.


First, you should remove the line for SSLCertificateChainFile. It will send extra certs since you already send the fullchain in SSLCertificateFile (which is best).

Have you enabled mod_ssl on your new server?

3 Likes