Redirection problem

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:certbot renew --dry-run

It produced this output:Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/ (success)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

My web server is (include version):Server version: Apache/2.4.7 (Ubuntu)

The operating system my web server runs on is (include version):Ubuntu 14.04.5 LTS

My hosting provider, if applicable, is:yes i have access to the server.

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

i have renewed the letsencrypt certificate but i have problem of redirection can you help me if possible.

Hi @buregeya

there is no redirect defined ( ):

Domainname Http-Status redirect Sec. G 200 1.226 H 200 1.190 H 200 2.680 I 200 2.746 I

But first you should renew your certificate, it's only 4 days valid.
expires in 4 days, - 2 entries


certbot -d -d

then Certbot should ask if you want to redirect http -> https.

And your chain is incomplete:

Chain - incomplete	

Looks like you have installed the certificate manual or if you have created the certificate with certonly.

PS: You have already created two new certificates:

CertSpotter-Id Issuer not before not after Domain names LE-Duplicate next LE
925741597 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2019-05-22 12:53:55 2019-08-20 12:53:55,
2 entries duplicate nr. 2
925725754 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2019-05-22 12:42:45 2019-08-20 12:42:45,
2 entries duplicate nr. 1

So don't select the "create" option, Certbot should ask if you want to reinstall that certificate.

i have renewed my certificate if i run this command:certbot renew
it shows me this:he following certs are not due for renewal yet:
/etc/letsencrypt/live/ expires on 2019-08-20 (skipped)
No renewals were attempted.
please help.

That's the reason you should use

certbot -d -d

so certbot can find the certificate and ask, if you want to install it.

Oh - I see the problem. What's your server software?


Date: Thu, 23 May 2019 09:55:13 GMT
Vary: Cookie,Accept-Encoding
Composed-By: SPIP 3.0.20 @ + spip(3.0.20),compagnon(1.4.1),dump(1.6.9),images(1.1.10),forum(1.8.40),jqueryui(1.8.21),mediabox(0.8.11),mots(2.4.13),msie_compat(1.2.0),organiseur(0.8.12),petitions(1.4.6),porte_plume(1.12.4),revisions(1.7.9),safehtml(1.4.1),sites(1.7.13),squelettes_par_rubrique(1.1.1),stats(0.4.28),svp(0.80.26),urls(1.4.26),vertebres(1.2.2),yaml(1.5.2),saisies(2.6.1),ckeditor(0.16.19),iterateurs(0.6.1),queue(0.6.6),breves(1.3.6),compresseur(1.8.11),medias(2.7.66),tw(0.8.30)
X-Spip-Cache: 86400
Last-Modified: Thu, 23 May 2019 09:55:13 GMT
Connection: close
Transfer-Encoding: chunked

There is no Apache/nginx header.

How did you install your current certificate?

Do that again.

i tried it again but get the same thing.
certbot -d -d
it is telling me certificate is renewed and it will expire in august.

No, you have created the next certificate. You have to install your existing certificate.

But it looks that certbot doesn't understand your configuration, so you have to install the certificate manual.

How did you install your last certificate?

What says

certbot certificates

i have used typed that command still giving me the same thing.
shows me it is renewed but it doesn’t.
i dont know where the problem is.

help me with all the steps to solve these.

There is your question:

Do that again.

this is the of the command cetbot certificates:Found the following certs:
Certificate Name:
Expiry Date: 2019-08-21 09:17:39+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/
Private Key Path: /etc/letsencrypt/live/

nothing changed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.