Raspberry apache2 SSL Certificate not

Dear all,
i already set up my synology and the letsencrypt certifcate is working well there.
now i wanted to use it for my apache2 on a raspberry also. the access is working from outside to the server.
However it looks like the certifcate is not loading?
Server version: Apache/2.4.53 (Raspbian)
Server built: 2022-03-14T16:28:35

i changed the config as described in the config file: ( /etc/apache2/sites-enabled/default-ssl.conf )

SSLCertificateFile      /etc/apache2/ownssl/fullchain.pem
SSLCertificateKeyFile /etc/apache2/ownssl/privkey.pem

and files are also there:

pi@raspberrypi:/etc/apache2 $ ll /etc/apache2/ownssl/
insgesamt 20
-r-------- 1 pi pi 1861  6. Apr 20:03 cert.pem
-r-------- 1 pi pi 3750  6. Apr 20:03 chain.pem
-r-------- 1 pi pi 5613  6. Apr 20:03 fullchain.pem
-r-------- 1 pi pi 1679  6. Apr 20:03 privkey.pem

on my domain for the port 8081 ( changed the https port to 8081 ) i get a login windows, but the access is insecure.

So SSL Port is working, but the certificate seems not to be loaded. Is there anything else i need to config?

edit: ah okay - the server redirect it to http instead of https.. :frowning:

edit2: solved it by changing the ports not only in ports.conf :slight_smile: everything works now as expected.


Welcome to the Let's Encrypt Community :slightly_smiling_face:

Glad to see that you were able to solve your own problem!


Thanks for letting us know. :smiley:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.