QNAP NAS trouble renewing certificate [moved to new topic]

Same problem to me, my certificate will be valid until 08.01.2024.

I'm lolcated in Germany too.

Kannst Du mich mal kontaktieren?
WeT-Klb at t-online.de

I just tried to renew again following the " Replacing the Server Certificate" from QNAP and run into the error message as in the screenshot.
Translation: "The domain name you are using has reached the maximum number of Let's Encrypt certificates"

How to resolve this?

Hi @Qnap.TQ,

Sorry to say but the answer is wait.

Testing and debugging are best done using the Staging Environment as the Rate Limits are much higher.
Also Duplicate Certificate Limit - Let's Encrypt

Hi @Qnap.TQ,

Also generally we like to keep each issue to its own Help Topic.
(kind of frowned on to hi jack another's Help Topic)


1 Like

It depends on the reason for the error. Some NAS vendors have their own limits. It that is stopping you then you'll have to ask their support.

If you post your domain name we can look at your problem more to see if it is related to Let's Encrypt.


OK, I'll wait that week, thank you.


A one week wait may not guarantee success.
If others are consuming the available seats as they are vacated...
You may find yourself still waiting for a seat [this time next week].

Your best bet is to switch your FQDN to a domain that isn't having such troubles.
But this is just a guess on my part as we don't yet know the exact domain name nor the exact trouble it is having.


Hello @Qnap.TQ welcome to the Let's Encrypt community. :slightly_smiling_face:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thank you for assisting us in helping YOU!

1 Like

My domain is: d89160scharabach18.myqnapcloud.com

I don't have answers to the other questions you raised. I just used the build in functionality of my QNAP NAS running on QTS firmware. Sorry, but I'm not a Pro.

May be I'm switching domain name to overcome that problem with the maximum number of Let's Encrypt certificates.

You are not exceeding a Let's Encrypt certificate rate limit. Have you asked about this problem on a QNAP forum?

You have only gotten one cert with that exact domain name and that was in October. Sometimes a shared name can reach a 50 certificate limit but in this case that root name is on the public suffix list so is not affected by that.

It would be helpful to know the exact reason why your device is saying some limit is being exceeded. If QNAP Has a log showing the exact error then maybe we can do something. Your best option is to contact their support for more details or assistance


For what ever reason now my certificate has been renewed using the build-in function of QNAP.
Thanks to all for helping.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.