Problems with letsencrypt, certbot, nextcloud and IPv6

The problem was that I enabled IPv6 portforwading at port 80 , but not 443. I enabled both port 80 and port 443 and now everything works fine.

(Sorry for bad English, I’m German)
Please Note: I replaced the IPv6 addresses with aaaa:aaaa:… or bbbb:bbbb:… in the following text, so that the text is easier to read.
I’m not sure if this is the right place to ask (or the nextcloud forum), but I have trouble setting up letsencrypt.

What I did:

  1. I downloaded the nextcloudpi image from here: and copied it to an sd card
  2. I configured my router in a way that Port 80 won’t be blocked (IPv6 port forwarding).
  3. I ran “$ sudo ip addr add aaaa:aaaa:aaaa:aaaa:cccc:cccc:cccc:cccc/64 dev eth0” on my server.
  4. I used to acquire a domain
  5. I ran “sudo nextcloudpi-config” -> “letsencrypt” -> “yes” -> “< mydomain >” ->“start”.
    Here is the output of the command:
    Launching letsencrypt
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Obtaining a new certificate
    Performing the following challenges:
    tls-sni-01 challenge for < mydomain >
    Waiting for verification…
    Cleaning up challenges
    Failed authorization procedure. < mydomain > (tls-sni-01): urn:acme:error:malformed :: The request message was malformed :: no working IP addresses found for “< mydomain >”


  • The following errors were reported by the server:

    Domain: < mydomain >
    Type: malformed
    Detail: no working IP addresses found for “< mydomain >”

    To fix these errors, please make sure that you did not provide any
    invalid information to the client, and try running Certbot again.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.
    Done. Press any key…

If I enter my domain in the browser bar, I get a notification that something is wrong with the certificate.
I would be thankful if anyone knows why this problem occures or how to fix it.

Additional information that may be useful:

OS: Raspbian
Root acces to server?: Yes

Please note: I have not configured IPv4 port forwarding and the IPv6 configuration is a bit messed up:
Running ifconfig on the server at first bootup to see what’s the IPv6 address produced the following output:
inet6 addr: aaaa:aaaa:aaaa:aaaa:bbbb:bbbb:bbbb:bbbb/64 Scope:Global
inet6 addr: fe80::cccc:cccc:cccc:cccc/64 Scope: link

I tried configure the router to forward aaaa:aaaa:aaaa:aaaa:bbbb:bbbb:bbbb:bbbb but that didn’t worked so I configured the router to forward aaaa:aaaa:aaaa:aaaa:cccc:cccc:cccc:cccc and ran “sudo ip addr add aaaa:aaaa:aaaa:aaaa:cccc:cccc:cccc:cccc/64 dev eth0” on the server. Now the output of ifconfig is:
inet6 addr: aaaa:aaaa:aaaa:aaaa:cccc:cccc:cccc:cccc/64 Scope:Global
inet6 addr: aaaa:aaaa:aaaa:aaaa:bbbb:bbbb:bbbb:bbbb/64 Scope:Global
inet6 addr: fe80::cccc:cccc:cccc:cccc/64 Scope: link

This site: is able to ping both aaaa:aaaa:aaaa:aaaa:cccc:cccc:cccc:cccc and < mydomain >

Use the full domain name you acquired instead of:

I did use the full domain name, but didn’t show that because of formatting problems. I fixed it.

Then, are you sure your domain can be resolved by global DNS systems?

Pretty Sure: is able to ping < mydomain >

place a test text file in the challenge folder.
see if you can access the test file from Internet via either:<>

I created the directory /var/www/nextcloud/.well-known/ and the files /var/www/nextcloud/test.html and /var/www/nextcloud/.well-known/acme-challenge.html . is available, is 404. If the name of the directory is .well-known , the site is 404, but if the name of the directory is well-known the site is available:

I think you are missing the acme-challenge folder.

I manually created the following files:

For some strange reason. Every path that has a directory that begins with “.” (hidden file) is 404, except for /var/www/nextcloud/.well-known/acme-challenge/test.txt . Is it possible that the apache webserver treats hidden files different.

I think that the Problem has something to do with IPv6 / IPv4 routing, because It’s a clean install of nextcloudpi, but the hole IPv6/IPv4 configuration is a bit messed up. There is no IPv4 portforwarding and running ifconfig prints multiple global IPv6 addresses, but only one of them is the correct one.

can you show the web server configuration file?

$ cat /etc/apache2/apache2.conf
# This is the main Apache server configuration file. It contains the
# configuration directives that give the server its instructions.
# See for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream’s suggested way to configure the web server. This is because Debian’s
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#	/etc/apache2/
#	|-- apache2.conf
#	|	`--  ports.conf
#	|-- mods-enabled
#	|	|-- *.load
#	|	`-- *.conf
#	|-- conf-enabled
#	|	`-- *.conf
# 	`-- sites-enabled
#	 	`-- *.conf
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.

# Global configuration

# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:>);
# you will save yourself a lot of trouble.
# Do NOT add a slash at the end of the directory path.
#ServerRoot "/etc/apache2"

# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#Mutex file:${APACHE_LOCK_DIR} default

# The directory where shm and other runtime files will be stored.

DefaultRuntimeDir ${APACHE_RUN_DIR}

# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars

# Timeout: The number of seconds before receives and sends time out.
Timeout 300

# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
KeepAlive On

# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
MaxKeepAliveRequests 100

# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
KeepAliveTimeout 5

# These need to be set in /etc/apache2/envvars

# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., (on) or (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
ErrorLog ${APACHE_LOG_DIR}/error.log

# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
Include ports.conf

# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
	Options FollowSymLinks
	AllowOverride None
	Require all denied

<Directory /usr/share>
	AllowOverride None
	Require all granted

<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride None
	Require all granted

#<Directory /srv/>
#	Options Indexes FollowSymLinks
#	AllowOverride None
#	Require all granted

# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
AccessFileName .htaccess

# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
<FilesMatch "^\.ht">
	Require all denied

# The following directives define some format nicknames for use with
# a CustomLog directive.
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
<IfModule mod_headers.c>
  Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
<IfModule mod_security2.c>
  SecServerSignature " "

OK, what about:
IncludeOptional conf-enabled/.conf
IncludeOptional sites-enabled/

# ls /etc/apache2/conf-enabled/
charset.conf  http2.conf  localized-error-pages.conf  other-vhosts-access-log.conf  php7.0-fpm.conf  security.conf  serve-cgi-bin.conf
# ls /etc/apache2/sites-enabled/
000-default.conf  nextcloud.conf

# cat sites-enabled/nextcloud.conf
<IfModule mod_ssl.c>
  <VirtualHost _default_:443>
    DocumentRoot /var/www/nextcloud
    CustomLog /var/www/nextcloud/data/access.log combined
    ErrorLog /var/www/nextcloud/data/error.log
    SSLEngine on
    SSLCertificateFile      /etc/ssl/certs/ssl-cert-snakeoil.pem
    SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
  <Directory /var/www/nextcloud/>
    Options +FollowSymlinks
    AllowOverride All
    <IfModule mod_dav.c>
      Dav off

# cat conf-enabled/security.conf 
# Disable access to the entire file system except for the directories that
# are explicitly allowed later.
# This currently breaks the configurations that come with some web application
# Debian packages.
#<Directory />
#   AllowOverride None
#   Require all denied

# Changing the following options will not really affect the security of the
# server, but might make attacks slightly more difficult in some cases.

# ServerTokens
# This directive configures what you return as the Server HTTP response
# Header. The default is 'Full' which sends information about the OS-Type
# and compiled in modules.
# Set to one of:  Full | OS | Minimal | Minor | Major | Prod
# where Full conveys the most information, and Prod the least.
#ServerTokens Minimal
ServerTokens OS
#ServerTokens Full

# Optionally add a line containing the server version and virtual host
# name to server-generated pages (internal error documents, FTP directory
# listings, mod_status and mod_info output etc., but not CGI generated
# documents or custom error documents).
# Set to "EMail" to also include a mailto: link to the ServerAdmin.
# Set to one of:  On | Off | EMail
#ServerSignature Off
ServerSignature On

# Allow TRACE method
# Set to "extended" to also reflect the request body (only for testing and
# diagnostic purposes).
# Set to one of:  On | Off | extended
TraceEnable Off
#TraceEnable On

# Forbid access to version control directories
# If you use version control systems in your document root, you should
# probably deny access to their directories. For example, for subversion:
#<DirectoryMatch "/\.svn">
#   Require all denied

# Setting this header will prevent MSIE from interpreting files as something
# else than declared by the content type in the HTTP headers.
# Requires mod_headers to be enabled.
#Header set X-Content-Type-Options: "nosniff"

# Setting this header will prevent other sites from embedding pages from this
# site as frames. This defends against clickjacking attacks.
# Requires mod_headers to be enabled.
#Header set X-Frame-Options: "sameorigin"

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

nextcloud.conf is 443 only.
what about “000-default.conf”

$ cat sites-enabled/000-default.conf 
<VirtualHost _default_:80>
  DocumentRoot /var/www/nextcloud
  <IfModule mod_rewrite.c>
    RewriteEngine Off
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

OK just after DocumentRoot add something along the lines of:

(lessthan symbol) IfModule alias_module>
Alias /.well-known/acme-challenge/ /var/www/nextcloud/.well-known/acme-challenge/
(lessthan symbol) /IfModule>

then for testing
echo “” > /var/www/nextcloud/.well-known/acme-challenge/test.txt
should then return “

If that fails, check that “alias_module” was loaded:
LoadModule alias_module modules/

I ran echo “” > /var/www/nextcloud/.well-known/acme-challenge/test.txt .
It works:

Try renewing cert again.

root@raspberrypi:/etc/letsencrypt# ./letsencrypt-auto certonly --renew --email -a manual -d --dry-run --agree-tos
  letsencrypt-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...

Certbot can obtain and install HTTPS/TLS/SSL certificates.  By default,
it will attempt to use a webserver both for obtaining and installing the
certbot: error: ambiguous option: --renew could match --renew-by-default, --renew-with-new-domains, --renew-hook

Maybe “renew” was a bad choice of word use.
Try your initial method to get a cert.