Problems with certificate chain on IIS


Hello there,

currently i run into some troubles with my lets encrypt setup.

I already had one sub-domain setup for LE manually(Just a quick test and it was working fine). Now the certifacate is expired and i wanted to use LE on my main domain. So i used Certify for the setup and it seemed to work fine.

But i got some troubles with firefox not accepting the certificate.

The sslab test says that the certificate chain is incomplete. But i dont now why. I’ve tried everything so far.

Server Key and Certificate #1
Issuer Let’s Encrypt Authority X3
Signature algorithm SHA256withRSA

Additional Certificates (if supplied)
Certificates provided 2 (2484 bytes)
Chain issues Incomplete, Extra certs

Subject Let’s Encrypt Authority X1
Fingerprint SHA1: 3eae91937ec85d74483ff4b77b07b43e2af36bf4
Valid until Mon, 19 Oct 2020 22:33:36 UTC (expires in 4 years and 4 months)
Key RSA 2048 bits (e 65537)
Issuer DST Root CA X3
Signature algorithm SHA256withRSA

Hope someone can help me with this…



Take a look at this post:


Thanks a lot.Solved the issue.

Was already getting mad :smiley: