Problems with Certbot and Snap

I am trying to follow the instructions here (https://certbot.eff.org/lets-encrypt/ubuntuxenial-nginx)

I have everything done up to the following

sudo snap install --classic certbot

I keep getting the following error

error: snap "certbot" is not available on stable but is available to install on the following channels:
edge snap install --edge certbot

Any advice on what I am potentionally doing wrong?

Did you first do?:
sudo snap install core

yes, I did all steps leading upto that point.

snap "core" is already installed, see 'snap help refresh'

When I run refresh I get
snap "core" has no updates available.

1 Like

Try also:
sudo apt update
sudo apt upgrade

just did both of those and I have the same error trying to install --classic certbot.

Try these instructions:
https://certbot.eff.org/lets-encrypt/snap-other

That has the same instructions up to the point I am failing. Snap can't seem to find Certbot on the stable channel.

@certbot-devs Did something go wrong with updating the certbot snap perhaps?

@azazael What's your architecture? I'm guessing not AMD64, correct?

It seems the certbot snap is only available for stable and beta on amd64, arm64 and armhf, but not for i386. For i386 only an older version of certbot (1.5.0?) on the channel "edge" is available.

2 Likes

Not exactly.
It has some apt remove steps.

uname -m tells me I am i686.

@rg305 If you are referring to step 4, the apt remove of existing certbots, that is in both and I did do that step.

The 32-bit snap had to be killed because Ubuntu fully dropped support for 32-bit platforms (around 19.10 I think). The Certbot snap is based on 20.04.

You can still install a very old version of Certbot from xenial-updates/bionic-updates and it should work for the remainder of the lifetime of those operating systems.

1 Like

Guess that is the final push I need to upgrade to 20.

1 Like

I may have been ambiguous - the architecture is the problematic bit. You can use the snap on Ubuntu 16.04 successfully, not just not on i386 ^^.

I gathered the architecture is the issue. I have been putting off an upgrade for awhile, if things are easier in 20 then I will just bite the bullet and upgrade things. I really should be on the LTS at this point anyway.

if the architecture is the main issue would it be possible to get the installation instructions to include options for those of us who don't have an architecture choice (I am locked into AMD Ryzen)?

All Ryzen processors are 64-bit.

You might have installed an i686 Ubuntu image inadvertently? Or are you running Linux inside virtualization?

If you download and install the regular amd64 image, everything should work fine.

I think I am running Linux inside a virtualization (Dedicated KVM Slice from Buy VM). Would that mean I am locked into i686? Sorry for the probably stupid question, I have a lot of learning to do about could hosted VM slices.

My first guess would be that you just need to choose the right VM image.

See how on https://buyvm.net/operating-systems/ubuntu/ there is a 32-bit and 64-bit version of each Ubuntu image?

I think you just need to select the 64-bit one.

1 Like

I would have thought I would have picked the 64bit version, maybe not.

Rebuilding the server doesn't sound a fun way to spend the tomorrow, but if means going to 64bit (assuming I did screw up and pick 32) it would be worth it. Unless Ubuntu would let me upgrade and then migrate my configs and everything over.