Problems Getting Started on a VPS (Justhost)


#1

using the command:

./letsencrypt-auto --agree-dev-preview --server \ https://acme-v01.api.letsencrypt.org/directory certonly

This is the output I get ?

Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
Package git-1.7.1-3.el6_4.1.x86_64 already installed and latest version
Package gcc-4.4.7-16.el6.x86_64 already installed and latest version
Package dialog-1.1-9.20080819.1.el6.x86_64 already installed and latest version
Package augeas-libs-1.0.0-10.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-42.el6.x86_64 already installed and latest version
Package libffi-devel-3.0.5-3.2.el6.x86_64 already installed and latest version
Package ca-certificates-2015.2.4-65.0.1.el6_6.noarch already installed and latest version
Nothing to do
WARNING: Python 2.6 support is very experimental at present…
if you would like to work on improving it, please ensure you have backups
and then run this script again with the --debug flag!


#2

From what I see on the JustHost web site the VPS servers they offer run CentOS 6.5 which comes with Python 2.6 and not 2.7 - which is kind of required by the letsencrypt-auto client.

I recall CentOS 6.5 problems being mentioned here and found three threads, just not sure if any offers a final solution: https://community.letsencrypt.org/search?q=centos%206.5


#3

Getting closer but still no cigar …
Here is what I have done that works:
first: stop the httpd service: /sbin/service httpd stop
then cd to letsencrypt: cd letsencrypt
then issue the command:
./letsencrypt-auto certonly --server \https://acme-v01.api.letsencrypt.org/directory --debug
two things to note:
1- NO SPACE between the “” and the server name
2- Must have the --debug option

a dialog box will come up asking for your email address
and then a dialog box will come up asking for your domain names

Was successfull and now see the certs in the directory
/etc/letsencrypt/live/thedomainnameyouputinthedialogbox

But - I don’t know where to go from here - the site still does not use the cert


#4

Success !!
After many frustrating attempts at trying to edit a vhosts and working with my helpdesk - they pointed me toward WHM as the solution. I just mailed myself the fullchain.pem and privkey.pem files that letsencrypt-auto installed in the /etc/letsencrypt/live/mydomain.com directory
Then I used WHM (SSL/TLS Install an SSL Certificate on a Domain) to install the certificates. The top part of the fullchain.pem goes in the “Certificate” box, privkey.pem goes in the “Private Key” box and the bottom part of the fullchain.pem in the “Certificate Authority Bundle” box.


#5

From my all time favorite TV commercial…
“Nobody said this was going to be easy”

Geico Cavemen Therapist 1 https://www.youtube.com/watch?v=qSHxHlRwmcI
Geico Cavemen Therapist 2 https://www.youtube.com/watch?v=6o4Q41DfV8k

Oh but wait, yes they did…
https://letsencrypt.org/howitworks/