Letsencrypt-auto fails on centos 6.7


#1

i got errors when i try to get certificates by the following command:
/opt/letsencrypt/letsencrypt-auto --config /etc/letsencrypt/cli.ini --debug certonly

i got the following output

Checking for new version…
Creating virtual environment…
Installing Python packages…
Requesting root privileges to run letsencrypt…
/root/.local/share/letsencrypt/bin/letsencrypt --no-self-upgrade --config /etc/letsencrypt/cli.ini --debug --dry-run certonly
Traceback (most recent call last):
File “/root/.local/share/letsencrypt/bin/letsencrypt”, line 5, in
from pkg_resources import load_entry_point
File “/root/.local/share/letsencrypt/lib/python2.6/site-packages/pkg_resources.py”, line 3007, in
working_set.require(requires)
File “/root/.local/share/letsencrypt/lib/python2.6/site-packages/pkg_resources.py”, line 728, in require
needed = self.resolve(parse_requirements(requirements))
File “/root/.local/share/letsencrypt/lib/python2.6/site-packages/pkg_resources.py”, line 626, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: unittest2

in /etc/letsencrypt/cli.ini are the following options

rsa-key-size = 4096

plugin

authenticator = webroot

webroot

webroot-path = /home/httpd/html/name/

domains

domains = domain.tld, test.domain.tld

flags

renew is good for automation

renew-by-default

i have root acces on a server with a fresh installed centos 6.7 and for the installation of letsencrypt i followed the instruction of https://www.svennd.be/lets-encrypt-with-centos-6/

what can i do?


#2

Hey sutter,

I documented the way I got it to work, however for most cases the official documentation should be sufficient. https://letsencrypt.org/howitworks/
As to this problem, I haven’t seen it myself, I just tried a dry run, and that worked… Only thing I can think of : is everything up-to-date ? yum update -y

If both methods don’t work you could try other clients, I have recently tried another one called letsencrypt.sh , but there are plenty see List of Client Implementations


#3

i did yum update. and i just tried it again. there were a few updates now and
opt/letsencrypt/letsencrypt-auto --config /etc/letsencrypt/cli.ini --debug --dry-run certonly
did an upgrade:
Upgrading letsencrypt-auto 0.3.0 to 0.4.0…

now its working. thank you for the hint!


#4

Glad you found it, another encryption-less website bites the dust :smiley: