Problemas na api do let's encrypt

Estou com problemas ao tentar gerar o certificado para meu site dentro do ambiente do meu servidor.
Ao verificar as configurações do módulo api vi que os endereços de base e palco apontam para os seguintes endereços:

Base: https://acme-v01.api.letsencrypt.org/
Palco: https://acme-staging.api.letsencrypt.org/
mais ao dar um ping nos endereços acima os mesmo retornam:

Ping request could not find host acme-staging.api.letsencrypt.org. Please check the name and try again.

Como posso solucionar o problema ?
Aguardo. Agradecido.

Por favor, preencha todos os campos abaixo para que nós possamos ajudar você. Obs.: você deve indicar seu nome de domínio para receber ajuda. Os nomes de domínio dos certificados emitidos são divulgados nos logs da Transparência de Certificados (por exemplo, https://crt.sh/?q=example.com). Assim, não indicar seu nome de domínio não o mantém em segredo, mas torna a nossa ajuda mais difícil.

Posso ler respostas em inglês: SIM

Meu nome de domínio é: tchibumpiscinas.ddns.net

Executei esse comando:

Produziu essa saída:

Meu servidor web é (com versão): IIS 8

O sistema operacional no meu servidor web é (com versão): Server 2012

O serviço de hospedagem do meu site (se aplicável) é:

Posso acessar um shell root na minha máquina (sim ou não, ou não sei): SIM

Uso um painel de controle para administrar meu site (não, ou indique o nome e a versão do painel de controle): SIM

2 Likes

Hello @Bobperes, welcome to the Let's Encrypt community. :slightly_smiling_face:

FYI -

Since the certificate presently being served has Signature algorithm SHA1withRSA INSECURE
from SSL Server Test: tchibumpiscinas.ddns.net (Powered by Qualys SSL Labs)

2 Likes

Bom dia @Bobperes,

A versão 1 da API ACME foi descontinuada em 2021:

Ela foi substituída pela versão 2, que tem outro endereço (acme-v02).

É por isso que o endereço velho não funciona mais. Um cliente atual terá e usará o endereço atual.

4 Likes