Problem with update certbot for apache on ubuntu

Hey guys,

Regarding this topic: How to stop using TLS-SNI-01 with Certbot i want to update my certbot version from 0.23 to latest. I’ve tried to do the install routine again:

  • $ sudo apt-get update
  • $ sudo apt-get install software-properties-common
  • $ sudo add-apt-repository universe
  • $ sudo add-apt-repository ppa:certbot/certbot
  • $ sudo apt-get update
  • $ sudo apt-get install python-certbot-apache

but after that i got the message: python-certbot-apache is already the newest version (0.28.0-1+ubuntu18.04.1+certbot+3) which sounds okay :slight_smile: but if i run certbot --version || /path/to/certbot-auto --version again it says certbot 0.23.0

My web server is (include version):
Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 18.04 LTS

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.23.0

Thank you guys!

Found a solution here: Version Upgrade

What i’ve done:
apt-get update & apt-cache policy certbot

sudo apt-get --with-new-pkgs upgrade because certbot kept back

and after that certbot --version || /path/to/certbot-auto --version says:
certbot 0.28.0

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.