Certbot Version the same after update


#1

Hello, in short, I followed the instructions to install certbot as a way of updating. I used the instructions for apache on ubuntu 16.04. But my certbot version stays the same (0.21.1), despite the output telling me it is updating to 0.28.0. Any suggestions? Thanks

My domain is: www.ifranks.com

I ran these commands:

$ certbot --version

$ sudo apt-get install python-certbot-apache

$ certbot --version

It produced this output:

certbot 0.21.1

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be upgraded:
python-certbot-apache
1 upgraded, 0 newly installed, 0 to remove and 180 not upgraded.
Need to get 3,872 B of archives.
After this operation, 3,072 B of additional disk space will be used.
Get:1 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial/main amd64 python-certbot-apache all 0.28.0-1+ubuntu16.04.1+certbot+3 [3,872 B]
Fetched 3,872 B in 0s (12.5 kB/s)
(Reading database … 34762 files and directories currently installed.)
Preparing to unpack …/python-certbot-apache_0.28.0-1+ubuntu16.04.1+certbot+3_all.deb …
Unpacking python-certbot-apache (0.28.0-1+ubuntu16.04.1+certbot+3) over (0.21.1-1+ubuntu16.04.1+certbot+1) …
Setting up python-certbot-apache (0.28.0-1+ubuntu16.04.1+certbot+3) …

certbot 0.21.1

My web server is (include version):

Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version):

Ubuntu 16.04

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

No


#2

Hi @jb5678,

I think it’s the same thing:


#3

Thanks, yes - my problem was exactly the same. I was trying to avoid running a full apt-get upgrade in case it caused any trouble elsewhere. In the end I cloned my server, so I could safely test upgrading everything…

apt-get update && apt-get upgrade

gave the message…

The following packages have been kept back:
certbot python3-acme python3-certbot python3-certbot-apache ubuntu-minimal

I allowed everything else to upgrade anyway and then ran (as you suggest)

apt-get --with-new-pkgs upgrade

Which gave the message…

The following NEW packages will be installed:
python3-requests-toolbelt ubuntu-advantage-tools
The following packages will be upgraded:
certbot python3-acme python3-certbot python3-certbot-apache ubuntu-minimal

This worked and Certbot --version is now reporting 0.28.0

Maybe its possible to simply install python3-requests-toolbelt & ubuntu-advantage-tools before trying to reinstall Certbot? I will test that if I have time.

I tried searching the forum but I didn’t find your post before so thanks for sharing.