Problem with subdomains


#1

Hi,

i install two certs with ./certbot-auto

In the first step i see two domains, they are running on this server. They have the same domain, but different subdomain. I choose the first, say redirect and so on, and i get an Congratulations message. The same by the other subdomain. But when i test it under www.ssllabs.com, i get an A Rating for the first, and a T for the second domain.

How can i do it correct?

Cheers
Kerstel


#2

Hi @kerstel

what’s your domain names? What commands did you use? What Server? Share your config files.


#3

Domain A, with Rating A, is gp-staging.mahlzeit.systems, Domain B, with rating T, is gpapi-staging.mahlzeit.systems.

This is the Output when i run the certbot-auto Script:

./certbot-auto
Requesting to rerun ./certbot-auto with root privileges...
[sudo] password for myadmin: 
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: jalaxi.han-solo.net
2: gp-staging.mahlzeit.systems
3: gpapi-staging.mahlzeit.systems
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 2
Cert not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn't close to expiry.
(ref: /etc/letsencrypt/renewal/gp-staging.mahlzeit.systems.conf)

What would you like to do?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 1
Keeping the existing certificate
Deploying Certificate to VirtualHost /etc/apache2/sites-enabled/gpapi-staging-le-ssl.conf

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you're confident your site works on HTTPS. You can undo this
change by editing your web server's configuration.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
Redirecting vhost in /etc/apache2/sites-enabled/gpapi-staging.conf to ssl vhost in /etc/apache2/sites-enabled/gpapi-staging-le-ssl.conf

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Congratulations! You have successfully enabled
https://gp-staging.mahlzeit.systems

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=gp-staging.mahlzeit.systems
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/gp-staging.mahlzeit.systems/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/gp-staging.mahlzeit.systems/privkey.pem
   Your cert will expire on 2018-11-28. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot-auto
   again with the "certonly" option. To non-interactively renew *all*
   of your certificates, run "certbot-auto renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le

And this by Domain B:

./certbot-auto
Requesting to rerun ./certbot-auto with root privileges...
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: jalaxi.han-solo.net
2: gp-staging.mahlzeit.systems
3: gpapi-staging.mahlzeit.systems
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 3
Cert not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn't close to expiry.
(ref: /etc/letsencrypt/renewal/gpapi-staging.mahlzeit.systems.conf)

What would you like to do?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 1
Keeping the existing certificate
Deploying Certificate to VirtualHost /etc/apache2/sites-enabled/gpapi-staging-le-ssl.conf

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you're confident your site works on HTTPS. You can undo this
change by editing your web server's configuration.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
Enhancement redirect was already set.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Congratulations! You have successfully enabled
https://gpapi-staging.mahlzeit.systems

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=gpapi-staging.mahlzeit.systems
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/gpapi-staging.mahlzeit.systems/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/gpapi-staging.mahlzeit.systems/privkey.pem
   Your cert will expire on 2018-11-28. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot-auto
   again with the "certonly" option. To non-interactively renew *all*
   of your certificates, run "certbot-auto renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le

This are the config file:

<VirtualHost 83.138.87.139:80>
        ServerAdmin webmaster@gpapi-staging.mahlzeit.systems
        DocumentRoot /var/www/gpapi-staging.mahlzeit.systems/current/public
        ServerName gpapi-staging.mahlzeit.systems
        ServerAlias gpapi-staging.mahlzeit.systems
        ErrorLog /var/www/gpapi-staging.mahlzeit.systems/current/storage/logs/error.log
        CustomLog /var/www/gpapi-staging.mahlzeit.systems/current/storage/logs/access.log common
        #RewriteEngine on
        #RewriteCond %{SERVER_NAME} =gpapi-staging.mahlzeit.systems
        #RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
RewriteEngine on
RewriteCond %{SERVER_NAME} =gpapi-staging.mahlzeit.systems
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<VirtualHost 83.138.87.139:80>
        ServerAdmin webmaster@gp-staging.mahlzeit.systems
        DocumentRoot /var/www/gp-staging.mahlzeit.systems/public
        ServerName gp-staging.mahlzeit.systems
        ServerAlias gp-staging.mahlzeit.systems
        ErrorLog /var/www/gp-staging.mahlzeit.systems/logs/error.log
        CustomLog /var/www/gp-staging.mahlzeit.systems/logs/access.log common
        #RewriteEngine on
        #RewriteCond %{SERVER_NAME} =gp-staging.mahlzeit.systems
        #RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
RewriteEngine on
RewriteCond %{SERVER_NAME} =gp-staging.mahlzeit.systems
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

And this is the ssl config file:

<IfModule mod_ssl.c>
    <VirtualHost 83.138.87.139:443>
        ServerAdmin webmaster@gp-staging.mahlzeit.systems
        DocumentRoot /var/www/gp-staging.mahlzeit.systems/public
        ServerName gp-staging.mahlzeit.systems
        ServerAlias gp-staging.mahlzeit.systems
        ErrorLog /var/www/gp-staging.mahlzeit.systems/logs/error.log
        CustomLog /var/www/gp-staging.mahlzeit.systems/logs/access.log common
        Include /etc/letsencrypt/options-ssl-apache.conf
        SSLCertificateFile /etc/letsencrypt/live/gp-staging.mahlzeit.systems/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/gp-staging.mahlzeit.systems/privkey.pem
    </VirtualHost>
</IfModule>
<IfModule mod_ssl.c>
    <VirtualHost 83.138.87.139:80>
        ServerAdmin webmaster@gpapi-staging.mahlzeit.systems
        DocumentRoot /var/www/gpapi-staging.mahlzeit.systems/current/public
        ServerName gpapi-staging.mahlzeit.systems
        ServerAlias gpapi-staging.mahlzeit.systems
        ErrorLog /var/www/gpapi-staging.mahlzeit.systems/current/storage/logs/error.log
        CustomLog /var/www/gpapi-staging.mahlzeit.systems/current/storage/logs/access.log common
        Include /etc/letsencrypt/options-ssl-apache.conf
        SSLCertificateFile /etc/letsencrypt/live/gpapi-staging.mahlzeit.systems/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/gpapi-staging.mahlzeit.systems/privkey.pem
    </VirtualHost>
</IfModule>

#4

Your first domain http://gp-staging.mahlzeit.systems/ is wrong, you send https over port 80.

That’s wrong in your ssl-configuration:

<VirtualHost 83.138.87.139:80>


#5

Now it works :wink: (ok, 20 character required!)


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.