Problem with payment processor


#1

Hi, do you mind explaining how to white list ip ?

I am stuck with a problem that both payment gateway & hosting provider can’t help because they think Let’s Encrypt SSL is blocking a POST action to an ip address.


IP addresses LE is validating from to build firewall rule
#2

Found this .well-known folder under public_html folder but how to you write that allow all in a filename?


#3

The IP address that LE is validating on has nothing to do with the blocking of a POST between your server and payment processor.


#4

@vinamelody, I agree with @serverco that this is a completely different, unrelated issue.

Try testing your site in https://www.ssllabs.com/ssltest/ to see if there is any misconfiguration that might be stopping the payment processor from connecting. For example, it could be missing the chain certificate.


#5

You can use a hook to temporarily allow access while you turn off your server

./certbot-auto certonly -d example.com \
    --standalone 
    --pre-hook='systemctl stop apache2.service && iptables -I INPUT -p tcp --dport 443 -j ACCEPT'
    --post-hook='iptables -D -p tcp --dport 443 -j ACCEPT && systemctl start apache2.service'

#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.