Problem with authorizing, not working


#1

I’m having a problem while using the installer. Everytime I try to register ssl for a domain, I get an error saying that the authorization failed. I even tried manual mode, no success. What’s up with this? How can I fix this problem?


#2

So apparently it’s a problem with DirectAdmin, since it does not support Let’s Encrypt yes.


#3

Can you provide any more details on the error you are getting?

Do you have SSH access to the machine?

Personally, I have a setup that not currently supported by the automated client (already have services running on port80/443 which the client couldn’t auto configure for.)

I’m currently using the webroot authenticator method that creates the challenges and put them in webroot/.well-known/acme-challenge/ which LE then checks.

And example of the command I run from ssh is:

./letsencrypt-auto -d example.com -d www.example.com --authenticator webroot --webroot-path /home/example/webroot/ --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory --rsa-key-size 4096 --renew-by-default auth

which will then put the certs in:

/etc/letsencrypt/live/example.com