Problem using certbot

My domain is:
I ran this command:

sudo certbot certonly --webroot -w /home/ubuntu/dockers/reverse/etc_nginx/bot -d
It produced this output:
An unexpected error occurred:
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/requests/", line 379, in prepare_url
scheme, auth, host, port, path, query, fragment = parse_url(url)
File "/usr/lib/python3/dist-packages/urllib3/util/", line 392, in parse_url
return six.raise_from(LocationParseError(source_url), None)
File "", line 3, in raise_from
urllib3.exceptions.LocationParseError: Failed to parse:

During handling of the above exception, another exception occurred:

requests.exceptions.InvalidURL: Failed to parse:
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version):

I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Welcome to the community @david_est

I think your problem will be fixed using the snap version of Certbot. See this thread for the same problem and solution. If that does not work for you due to some environment problem please post back.


Great, many many thanks
issue has been solved


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.