Php bin/acme setup --server 'letsencrypt' --email 'admin@domain_name'

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: php bin/acme setup --server ‘letsencrypt’ --email ‘’

It produced this output: Amp\Dns\TimeoutException: No response for ‘’ (MX) from any nameserver after 2 attempts, tried udp://, udp:// in /home/user/acme-client/vendor/amphp/dns/lib/BasicResolver.php:299 Next Kelunik\Acme\AcmeException: Dns query for an MX record on ‘’ failed for the following reason: No response for ‘’ (MX) from any nameserver after 2 attempts, tried udp://, udp:// in /home/user/acme-client/src/Commands/Setup.php:83

My web server is (include version): Hostinger Shared Hosting

The operating system my web server runs on is (include version): Linux 3.10.0-962.3.2.lve1.5.26.3.el7.x86_64 #1 SMP Wed Aug 14 08:29:59 EDT 2019 x86_64

My hosting provider, if applicable, is: Hostinger

I can login to a root shell on my machine (yes or no, or I don’t know): Using Putty, I managed to login.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Hostinger’s panel to manage my website. But I am using putty to access SSH.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Don’t know but I installed it on 01/09/2020.

1 Like

I think the problem is that the program you are using ( tries to do a self-check of your email address, but fails due to something being off with the DNS resolvers in your shared hosting environment.

Unfortunately the program doesn’t seem to provide a way to skip the checks.

I’m not sure there’s anything you can do about it.

You could ask the author of the program to provide a way to skip those checks. As a general principle this should always be an option, because self-checks will never be perfectly reliable.

You could also try provide a GMail address or something instead, that might not run into the same DNS issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.