Opera 34 browser


#1

Latest Opera browser is 34 (.deb and Win). It refuses to display pages protected by letsencrypt at https://wiki.koha-community.org. After much searching, I have “force fed” it:

  • ISRG Root X1
  • Let’s Encrypt Authority X1 (IdenTrust cross-signed)
  • Let’s Encrypt Authority X2 (IdenTrust cross-signed)
  • DST Root CA X3
    which all appear to be properly installed. But still cannot get past the message “the server presented an invalid certificate. You cannot proceed because the website operator has requested heightened security for this domain.” The page in question display fine in Firefox.
    Where next, please. Tnx – Paul

#2

FYI, Opera 34 for Mac just works fine. I’m not sure if this is a platform specific issue. Have you tried with Opera on a different device/network?


#3

Works fine here on Mageia 5 Opera 34.


#4

Weppos – thanks. Tried on two platforms: WinXP Pro (probably will never work, but we use a few older machines as kiosks in the library and are not going to pay for an upgrade license); and a number of desktops with Debian, Ubuntu and Mint – now finally working after installing the four certificates (as in my first post) and rebooting (a rare thing to have to do with Linux boxen.)
Many thanks all around.

I think this resolves the problem, unless someone has a fix for WinXP?

Best – Paul


#5

Unfortunately, there’s a bug in Windows XP… Every browser that uses the XP OS SSL stack is affected by this (i.e. not Firefox, as Fx uses its own SSL stack [NSS]).