Nothing provides python-augeas needed by python2-certbot-apache-0.31.0-1.el7.noarch

Any help you could provide would be much appreciated.

I ran this command: yum install certbot python2-certbot-apache

It produced this output:
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Last metadata expiration check: 1:46:43 ago on Tue 28 May 2019 08:25:55 AM UTC.
Error:
Problem 1: conflicting requests

  • nothing provides python-augeas needed by python2-certbot-apache-0.31.0-1.el7.noarch
    Problem 2: package certbot-0.31.0-2.el7.noarch requires python2-certbot = 0.31.0-2.el7, but none of the providers can be installed
  • conflicting requests
  • nothing provides python-setuptools needed by python2-certbot-0.31.0-2.el7.noarch
  • nothing provides pytz needed by python2-certbot-0.31.0-2.el7.noarch
  • nothing provides python-configobj needed by python2-certbot-0.31.0-2.el7.noarch
  • nothing provides python-zope-interface needed by python2-certbot-0.31.0-2.el7.noarch
  • nothing provides python2-cryptography needed by python2-certbot-0.31.0-2.el7.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

My web server is (include version): NAME=“Red Hat Enterprise Linux”
VERSION=“8.0 (Ootpa)”
ID=“rhel”
ID_LIKE=“fedora”
VERSION_ID=“8.0”
PLATFORM_ID=“platform:el8”
PRETTY_NAME=“Red Hat Enterprise Linux 8.0 (Ootpa)”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:redhat:enterprise_linux:8.0:GA”
HOME_URL=“https://www.redhat.com/
BUG_REPORT_URL=“https://bugzilla.redhat.com/

REDHAT_BUGZILLA_PRODUCT=“Red Hat Enterprise Linux 8”
REDHAT_BUGZILLA_PRODUCT_VERSION=8.0
REDHAT_SUPPORT_PRODUCT=“Red Hat Enterprise Linux”
REDHAT_SUPPORT_PRODUCT_VERSION=“8.0”

My hosting provider, if applicable, is:AWS

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no

Comparing these two lists:

It seems like you may be attempting to install a RHEL7 package onto a RHEL8 system. This won’t work. You’ll want to track down some RHEL8-specific certbot packages, or install using another method (e.g. python pip, or from source, etc).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.