Apache on Centos 7 - Dependency Issues


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
non right now, just prepping the server for it

I ran this command:

sudo yum install python2-certbot-apache, I also tried sudo yum install python2-certbot same output

It produced this output:

sudo yum install python2-certbot-apache
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: fedora-epel.mirrors.tds.net
 * extras: ftp.osuosl.org
 * updates: ftp.osuosl.org
Resolving Dependencies
--> Running transaction check
---> Package python2-certbot-apache.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: python2-certbot >= 0.26.0 for package: python2-certbot-apache-0.26.1-1.el7.noarch
--> Processing Dependency: python2-acme >= 0.25.0 for package: python2-certbot-apache-0.26.1-1.el7.noarch
--> Processing Dependency: certbot >= 0.21.1 for package: python2-certbot-apache-0.26.1-1.el7.noarch
--> Processing Dependency: python-augeas for package: python2-certbot-apache-0.26.1-1.el7.noarch
--> Running transaction check
---> Package certbot.noarch 0:0.26.1-1.el7 will be installed
---> Package python2-acme.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pyOpenSSL >= 0.13 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: pytz for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-six for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-requests for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-pyrfc3339 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-pyasn1 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-josepy for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python-requests-toolbelt for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python-ndg_httpsclient for package: python2-acme-0.26.1-1.el7.noarch
---> Package python2-certbot.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pytz for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-mock for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-future for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-configargparse for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python-zope-interface for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python-zope-component for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python-parsedatetime for package: python2-certbot-0.26.1-1.el7.noarch
---> Package python2-certbot-apache.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: python-augeas for package: python2-certbot-apache-0.26.1-1.el7.noarch
--> Running transaction check
---> Package python-ndg_httpsclient.noarch 0:0.3.2-1.el7 will be installed
--> Processing Dependency: python-pyasn1 for package: python-ndg_httpsclient-0.3.2-1.el7.noarch
--> Processing Dependency: pyOpenSSL for package: python-ndg_httpsclient-0.3.2-1.el7.noarch
---> Package python-requests-toolbelt.noarch 0:0.8.0-1.el7 will be installed
---> Package python-zope-component.noarch 1:4.1.0-3.el7 will be installed
--> Processing Dependency: python-zope-interface for package: 1:python-zope-component-4.1.0-3.el7.noarch
--> Processing Dependency: python-zope-event for package: 1:python-zope-component-4.1.0-3.el7.noarch
---> Package python2-acme.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pyOpenSSL >= 0.13 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: pytz for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-pyasn1 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-acme-0.26.1-1.el7.noarch
---> Package python2-certbot.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pytz for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python-zope-interface for package: python2-certbot-0.26.1-1.el7.noarch
---> Package python2-certbot-apache.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: python-augeas for package: python2-certbot-apache-0.26.1-1.el7.noarch
---> Package python2-configargparse.noarch 0:0.11.0-1.el7 will be installed
---> Package python2-future.noarch 0:0.16.0-6.el7 will be installed
---> Package python2-josepy.noarch 0:1.1.0-1.el7 will be installed
--> Processing Dependency: python2-cryptography for package: python2-josepy-1.1.0-1.el7.noarch
--> Processing Dependency: pyOpenSSL for package: python2-josepy-1.1.0-1.el7.noarch
---> Package python2-mock.noarch 0:1.0.1-9.el7 will be installed
---> Package python2-parsedatetime.noarch 0:2.4-5.el7 will be installed
---> Package python2-pyrfc3339.noarch 0:1.0-2.el7 will be installed
---> Package python2-requests.noarch 0:2.6.0-0.el7 will be installed
---> Package python2-six.noarch 0:1.9.0-0.el7 will be installed
--> Running transaction check
---> Package python-ndg_httpsclient.noarch 0:0.3.2-1.el7 will be installed
--> Processing Dependency: python-pyasn1 for package: python-ndg_httpsclient-0.3.2-1.el7.noarch
--> Processing Dependency: pyOpenSSL for package: python-ndg_httpsclient-0.3.2-1.el7.noarch
---> Package python-zope-component.noarch 1:4.1.0-3.el7 will be installed
--> Processing Dependency: python-zope-interface for package: 1:python-zope-component-4.1.0-3.el7.noarch
---> Package python-zope-event.noarch 0:4.0.3-2.el7 will be installed
---> Package python2-acme.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pyOpenSSL >= 0.13 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: pytz for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-pyasn1 for package: python2-acme-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-acme-0.26.1-1.el7.noarch
---> Package python2-certbot.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: pytz for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python2-cryptography for package: python2-certbot-0.26.1-1.el7.noarch
--> Processing Dependency: python-zope-interface for package: python2-certbot-0.26.1-1.el7.noarch
---> Package python2-certbot-apache.noarch 0:0.26.1-1.el7 will be installed
--> Processing Dependency: python-augeas for package: python2-certbot-apache-0.26.1-1.el7.noarch
---> Package python2-josepy.noarch 0:1.1.0-1.el7 will be installed
--> Processing Dependency: python2-cryptography for package: python2-josepy-1.1.0-1.el7.noarch
--> Processing Dependency: pyOpenSSL for package: python2-josepy-1.1.0-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-ndg_httpsclient-0.3.2-1.el7.noarch (epel)
           Requires: python-pyasn1
Error: Package: python2-acme-0.26.1-1.el7.noarch (epel)
           Requires: pytz
Error: Package: python-ndg_httpsclient-0.3.2-1.el7.noarch (epel)
           Requires: pyOpenSSL
Error: Package: python2-certbot-0.26.1-1.el7.noarch (epel)
           Requires: python-zope-interface
Error: Package: python2-certbot-0.26.1-1.el7.noarch (epel)
           Requires: pytz
Error: Package: python2-certbot-0.26.1-1.el7.noarch (epel)
           Requires: python2-cryptography
Error: Package: python2-certbot-apache-0.26.1-1.el7.noarch (epel)
           Requires: python-augeas
Error: Package: python2-acme-0.26.1-1.el7.noarch (epel)
           Requires: pyOpenSSL >= 0.13
Error: Package: python2-acme-0.26.1-1.el7.noarch (epel)
           Requires: python2-pyasn1
Error: Package: python2-acme-0.26.1-1.el7.noarch (epel)
           Requires: python2-cryptography
Error: Package: python2-josepy-1.1.0-1.el7.noarch (epel)
           Requires: python2-cryptography
Error: Package: python2-josepy-1.1.0-1.el7.noarch (epel)
           Requires: pyOpenSSL
Error: Package: 1:python-zope-component-4.1.0-3.el7.noarch (epel)
           Requires: python-zope-interface
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My web server is (include version):

Apache 2.4.6
The operating system my web server runs on is (include version):
CentOS Linux release 7.5.1804
My hosting provider, if applicable, is:
Digital Ocean
I can login to a root shell on my machine (yes or no, or I don’t know):
Yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.