Not found when trying to install cert using certbot


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: intueri.no www.intueri.no

I ran this command: sudo certbot --nginx -d intueri.no -d www.intueri.no --staging
(and, foolislhy, 5 timer without staging)

It produced this output:
www.intueri.no --staging
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for intueri.no
http-01 challenge for www.intueri.no
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.intueri.no (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.intueri.no/.well-known/acme-challenge/sQGa9dyVfMMu9MLMjuKXVVCG8BCGTRH-DGM6h1w23vk: "
404 Not Found

404 Not Found



", intueri.no (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://intueri.no/.well-known/acme-challenge/_5EAUhoJcTDbimxkOcYAFoTdJtSXbuRds6CvddXTlWg: "
404 Not Found

404 Not Found



"
IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: www.intueri.no
   Type:   unauthorized
   Detail: Invalid response from
   http://www.intueri.no/.well-known/acme-challenge/sQGa9dyVfMMu9MLMjuKXVVCG8BCGTRH-DGM6h1w23vk:
   "<html>
   <head><title>404 Not Found</title></head>
   <body bgcolor="white">
   <center><h1>404 Not Found</h1></center>
   <hr><center>"

   Domain: intueri.no
   Type:   unauthorized
   Detail: Invalid response from
   http://intueri.no/.well-known/acme-challenge/_5EAUhoJcTDbimxkOcYAFoTdJtSXbuRds6CvddXTlWg:
   "<html>
   <head><title>404 Not Found</title></head>
   <body bgcolor="white">
   <center><h1>404 Not Found</h1></center>
   <hr><center>"

I’ve quadruplechecked both IPv4 and IPv6 at domain host, verification worked just fine for another site (simple php site, this is a grav cms site)

My web server is (include version): nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: https://domene.shop/

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Nginx config for site: https://dpaste.de/wcWB


#2

Hi @vimes

I don’t find an explicit error. Your ipv6 / ipv4 - configuration looks ok,

https://letsdebug.net/www.intueri.no/5189?debug=y

doesn’t find an error. Looks like you use a content management system GravCMS, perhaps that blocks something.

That

location ~* /(system|vendor)/.*\.(txt|xml|md|html|yaml|yml|php|pl|py|cgi|twig|sh|bat)$ { return 403; }

looks like there are rules used with windows- and linux - systems.

To test: Create two subdirectories

yourwebroot/.well-known/acme-challenge

there place a file with name 123456789 (without file extension) and a simple content.

Then try, if you can load this file via

http://www.intueri.no/.well-known/acme-challenge/123456789

Perhaps there are other rules which block this.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.