No valid IP address found

My domain is: msrvps.msrwork.moe

I ran this command: lnmp ssl add

It produced this output:
Please enter domain(example: www.lnmp.org): msrvps.msrwork.moe
Your domain: msrvps.msrwork.moe
Enter more domain name(example: lnmp.org *.lnmp.org):
Please enter the directory for domain msrvps.msrwork.moe: /home/wwwroot/vps
Allow Rewrite rule? (y/n) n
You choose rewrite: none
Allow access log? (y/n) n
Disable access log.
Enable PHP Pathinfo? (y/n) n
Disable pathinfo.
1: Use your own SSL Certificate and Key
2: Use Let’s Encrypt to create SSL Certificate and Key
Enter 1 or 2: 2
It will be processed automatically.
/usr/local/acme.sh/acme.sh [found]
Starting create SSL Certificate use Let’s Encrypt…
[Fri Jun 5 16:45:29 CST 2020] Single domain=‘msrvps.msrwork.moe’
[Fri Jun 5 16:45:29 CST 2020] Getting domain auth token for each domain
[Fri Jun 5 16:45:42 CST 2020] Getting webroot for domain=‘msrvps.msrwork.moe’
[Fri Jun 5 16:45:42 CST 2020] Verifying: msrvps.msrwork.moe
[Fri Jun 5 16:45:53 CST 2020] Pending
[Fri Jun 5 16:45:59 CST 2020] msrvps.msrwork.moe:Verify error:No valid IP addresses found for msrvps.msrwork.moe
[Fri Jun 5 16:45:59 CST 2020] Please check log file for more details: /usr/local/acme.sh/acme.sh.log
Let’s Encrypt SSL Certificate create failed!

My web server is (include version): nginx/1.16.1

The operating system my web server runs on is (include version): CentOS 7 7.7.1908 (Core)

My hosting provider, if applicable, is: GigsGigsCloud

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): None

Additional Info:
I was using LNMP one-click installation pack from https://lnmp.org for hosting. Some of my old domains and all of my new domains cannot acquire SSL certifications. The domain provided above is my main project and need to apply for it as soon as possible.
A record already added. I used https://unboundtest.com/ to lookup my domain IP and it got the correct response (maybe?). The result is here: https://unboundtest.com/m/A/msrvps.msrwork.moe/MJ3JP6ZL
I tried multiple hosting provider and the results are the same.
I’m not experienced but really want to resolve the problem, please help!

1 Like

Hi @bbs3223474

there is a check of your domain - https://check-your-website.server-daten.de/?q=msrvps.msrwork.moe

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
msrvps.msrwork.moe Refused yes 1 0
www.msrvps.msrwork.moe Refused yes 1 0
msrvps.msrwork.moe A 27.122.58.207 Los Angeles/California/United States (US) - Techavenue International Ltd No Hostname found no

Refused-answers.

Only the non-authoritative check has an ip address.

Your dns27.hichina.com name server has a refused answer.

Your gdns1.interlink.or.jp answers correct.

Looks like your name server configuration is broken. Your delegation:

;; AUTHORITY SECTION:
msrwork.moe. 3600 IN NS dns28.hichina.com.
msrwork.moe. 3600 IN NS dns27.hichina.com.
msrwork.moe. 3600 IN NS gdns1.interlink.or.jp.
msrwork.moe. 3600 IN NS gdns2.interlink.or.jp.

So if Unboundtest picks the jp name servers, it works. If a resolver picks the hichina servers, it doesn’t work.

Update your name server configuration so the hichina servers aren’t delegated.

2 Likes

Thank you for your support!
I changed nameserver settings long time ago and didn’t realize that’s the issue.
All problem solved.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.