No crontab or system timer entries created

Hello!

Thank you for doing all the hard work to create and maintain certbot. It's a great tool and resource for the community to connect with LetsEncrypt.

In the documentation (Certbot - Debianbuster Nginx), there is reference to behavior in certbot that will "automatically" create either a crontab entry or system timer when a certificate is issued. I have tried and tried but see no such entry being created.

I am more than comfortable creating the entry on my own, but I want to make sure I understand why the client is not doing what the documentation says it will. I am worried that I am doing something wrong that will screw things up in the future.

I have included below the command that I used to get the certificate.

Thank you for explaining what I am missing!

Will

My domain is:
pad.opentechstrategies.com

I ran this command:
certbot certonly -w /root/etherpad/webroot/ -d pad.opentechstrategies.com --preferred-challenges http

The operating system my web server runs on is (include version):
Linux Debian 4.19.132-1 (2020-07-24)

I can login to a root shell on my machine (yes or no, or I don't know):
yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
1.14.0

1 Like

Hi @hawkinsw, and welcome to the LE community forum :slight_smile:

I'm assuming this command failed:

Try it including --webroot:
certbot certonly --webroot -w /root/etherpad/webroot/ -d pad.opentechstrategies.com

1 Like

Actually, that command worked just fine!

1 Like

Please show the output of:
certbot certificates
certbot --version

1 Like
Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Found the following certs:
  Certificate Name: pad.opentechstrategies.com
    Serial Number: 3ca079597a1824e0d53ab61cb030a8a1e10
    Key Type: RSA
    Domains: pad.opentechstrategies.com
    Expiry Date: 2021-08-01 06:11:04+00:00 (VALID: 89 days)
    Certificate Path: /etc/letsencrypt/live/pad.opentechstrategies.com/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/pad.opentechstrategies.com/privkey.pem
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
root@ots-etherpad:~# certbot --version
certbot 1.14.0
1 Like

Thank you for your help! :slight_smile:

2 Likes

So far, so good...

How about:
sudo crontab -u root -l
sudo systemctl list-timers

1 Like

So sorry! I was misinterpreting the output of systemctl list-timers. Everything is a-okay! I am so sorry for wasting your time!

Will

2 Likes

No worries.
This topic may still serve helpful to anyone with a similar problem - lol

Cheers from Miami :beers:

2 Likes

Thanks again!

The key for me was piping the output from systemctl --list-timers to more so that I could see the name of the UNIT despite the fact that I was running on an 80 column term.

Enjoy sunny Miami!

3 Likes