Nginx: configuration file /etc/nginx/nginx.conf test failed

Veuillez remplir les champs ci-dessous pour que nous puissions vous aider. Remarque : vous devez fournir votre nom de domaine pour obtenir de l’aide. Les noms de domaine des certificats émis sont tous rendus publics dans les journaux de Transparence de Certificat (par exemple, https://crt.sh/?q=example.com). Par conséquent, le fait de ne pas indiquer votre nom de domaine ici n’aide pas à le garder secret, mais rend plus difficile pour nous le fait de vous aider.

Je peux lire des réponses en Anglais :non

Mon nom de domaine est : monserveur2016.hopto.org

J’ai exécuté cette commande : systemctl status nginx.service

Elle a produit cette sortie :nginx: configuration file /etc/nginx/nginx.conf test failed

Mon serveur Web est (inclure la version) :

Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) : Openmediavault 4

Mon hébergeur, le cas échéant, est :

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) :oui

J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) :

Après avoir suivi ce tuto concernant le renouvellement de certificat letsencrypt avec acme.sh : https://mondedie.fr/d/10789-[Tuto]-Renouveler-vos-certificats-Let’s-Encrypt-automatiquement-(acme.sh-nginx), je me retrouve toujours avec ce problème : impossible de démarrer le service nginx. En tutilisant cette commande : systemctl status nginx.service, il semble que ce soit mon fichier de config nginx qui ait un défaut. Aussi je me permets de le poster en demandant votre aide svp.

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##

gzip on;
gzip_disable "msie6";

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;

}

#mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities “TOP” “USER”;

# imap_capabilities “IMAP4rev1” “UIDPLUS”;

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

#}

avec la commande nginx -t , voilà ce que ca donne :
nginx: [warn] duplicate value “TLSv1.2” in /etc/nginx/conf.d/ssl.conf:1

voici ce que contient ce fichier ssl.conf:
ssl_protocols TLSv1.2;
ssl_ecdh_curve X25519:-521:-384:-256;
ssl_ciphers “EECDH+CHACHA20:EECDH+AES”;
ssl_prefer_server_ciphers on;

ssl_session_cache shared:SSL:20m;
ssl_session_timeout 15m;
ssl_session_tickets off;

nginx: [emerg] “ssl_prefer_server_ciphers” directive is duplicate in /etc/nginx/conf.d/ssl.conf:4

nginx: configuration file /etc/nginx/nginx.conf test failed

ssl_prefer_server_ciphers est en double, il faut retirer l’un des deux et re-tester.

Merci pour votre aide, je devais retirer les 2 lignes.