NextCloud issuance error: "Nope, it's not there" domain unreachable


#1

Please fill out the fields below so we can help you better.

My domain is: hogtun.jensenslekta.com

I ran this command: sudo ./var/scripts/activate-ssl.sh

It produced this output: Setting up nmap (7.01-2ubuntu2) …
Port 443 is open on 85.167.233.56!
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libblas-common libblas3 liblinear3 liblua5.2-0 lua-lpeg ndiff python-bs4
python-html5lib python-lxml
Use ‘sudo apt autoremove’ to remove them.
The following packages will be REMOVED:
nmap*
0 upgraded, 0 newly installed, 1 to remove and 5 not upgraded.
After this operation, 21.3 MB disk space will be freed.
(Reading database … 99158 files and directories currently installed.)
Removing nmap (7.01-2ubuntu2) …
Processing triggers for man-db (2.7.5-1) …

Checking if hogtun.jensenslekta.com exists and is reachable…
Nope, it’s not there. You have to create hogtun.jensenslekta.com and point
it to this server before you can run this script.

My operating system is (include version): Ubuntu 16.04 VM (Nextcloud VM)

My web server is (include version): Apache version 2.4.18

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hello @johansenmeister,

Seems you are using some kind of script provided by nextcloud to obtain the Let’s Encrypt certificate and I suppose this is the script you are using https://github.com/nextcloud/vm/blob/master/lets-encrypt/activate-ssl.sh

Checking the script, the error you got is because the script is trying to reach your domain using this command:

wget -q -T 10 -t 2 hogtun.jensenslekta.com

and it fails to connect to your web server… I also tried it and I can’t connect to your web server so seems you should double check that your web server is up and running and there is no firewall etc. blocking the connection.

Cheers,
sahsanu


#3

Hi, thank you for the reply!

Yes that is the script I am using. I cannot figure this out. The port is forwarded correctly, I know this because I can reach Nextcloud from my mobile phone by using https://hogtun.jensenslekta.com

By the way, I installed my parents nextcloud server from this ip too, meaning to set it up at their house later, using arbeidssky.jensenslekta.com (points to 85.167.233.56) and this worked fine. Could there be a conflict? Is it one certificate per IP?

This output is from my server console:

ncadmin@hogtun:~$ ping hogtun.jensenslekta.com
PING hogtun.jensenslekta.com (85.167.233.56) 56(84) bytes of data.
64 bytes from ti0163a400-0564.bb.online.no (85.167.233.56): icmp_seq=1 ttl=64 time=0.618 ms
64 bytes from ti0163a400-0564.bb.online.no (85.167.233.56): icmp_seq=2 ttl=64 time=0.634 ms
64 bytes from ti0163a400-0564.bb.online.no (85.167.233.56): icmp_seq=3 ttl=64 time=0.672 ms
^C
hogtun.jensenslekta.com ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2022ms
rtt min/avg/max/mdev = 0.618/0.641/0.672/0.030 ms
ncadmin@hogtun:~$ wget -q -T 10 -t 2 hogtun.jensenslekta.com
ncadmin@hogtun:~$


#4

Yes, there is no problem to reach your server on port 443 but there is no connection on port 80

There should be no conflict at all, modern web servers (as the Apache server you are using) supports SNI so you can have several certificates for different domains on the same ip.

As I said, that command will try to reach your server on port 80, to know whether the command finishes ok or in error, you should execute echo $? just immediately after the wget command.

ncadmin@hogtun:~$ wget -q -T 10 -t 2 hogtun.jensenslekta.com
ncadmin@hogtun:~$ echo $?

If after the echo $? you get a 0 the command wget executed ok, if you receive a number greater than 0 the command failed which means that it can’t reach your domain on port 80.

Instead of execute the wget and the echo $? you can use this command and it will say if the command Failed or terminated with success:

wget -q -T 10 -t 2 hogtun.jensenslekta.com && echo "Success" || echo "Failed"

Cheers,
sahsanu


#5

Thank you soooo much sahsanu!

Opening port 80 did solve the problem right away :slight_smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.